summaryrefslogtreecommitdiff
path: root/qpid/cpp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/Makefile.am')
-rw-r--r--qpid/cpp/Makefile.am23
1 files changed, 0 insertions, 23 deletions
diff --git a/qpid/cpp/Makefile.am b/qpid/cpp/Makefile.am
index a996db4eac..8e73ba5777 100644
--- a/qpid/cpp/Makefile.am
+++ b/qpid/cpp/Makefile.am
@@ -1,12 +1,8 @@
AUTOMAKE_OPTIONS = 1.9.2 foreign
ACLOCAL_AMFLAGS = -I m4
-SPEC=$(PACKAGE).spec
-
EXTRA_DIST = \
LICENSE NOTICE README RELEASE_NOTES DESIGN\
- $(SPEC) $(SPEC).in \
- rpm/README.qpidd-devel \
xml/cluster.xml
SUBDIRS = managementgen etc src docs/api docs/man examples
@@ -15,24 +11,5 @@ SUBDIRS = managementgen etc src docs/api docs/man examples
libtool: $(LIBTOOL_DEPS)
$(SHELL) ./config.status --recheck
-#
-# Build RPMs from the distribution tarball.
-#
-RPMDIRS=rpm/BUILD rpm/RPMS rpm/SPECS rpm/SRPMS
-RPMMACROS=--define "_topdir @abs_builddir@/rpm" --define "_sourcedir @abs_builddir@"
-# Override this variable e.g. with -bs to produce srpm only
-RPMOPTS=-ba
-
-clean-local:
- -rm -rf $(RPMDIRS)
-.PHONY: rpmbuild
-rpmbuild: $(SPEC) dist-gzip
- mkdir -p $(RPMDIRS)
- QPID_PYTHON_DIR=@abs_top_srcdir@/../python rpmbuild $(RPMMACROS) $(RPMOPTS) $(SPEC)
-if HAS_RPMLINT
- rpmlint `find rpm -name '*.rpm'`
-else
- @echo "WARNING: rpmlint not found, could not validate RPMs."
-endif