summaryrefslogtreecommitdiff
path: root/qpid/cpp/boost-1.32-support/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/boost-1.32-support/Makefile')
-rw-r--r--qpid/cpp/boost-1.32-support/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/qpid/cpp/boost-1.32-support/Makefile b/qpid/cpp/boost-1.32-support/Makefile
new file mode 100644
index 0000000000..8b521a1aa3
--- /dev/null
+++ b/qpid/cpp/boost-1.32-support/Makefile
@@ -0,0 +1,29 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+.PHONY: default apply
+
+default:
+ @echo "Run 'make apply' to patch the source"
+
+apply: main.patch ../src/boost
+ patch -d .. -p0 < main.patch
+ cat supressions >> ../src/tests/.valgrind.supp
+
+../src/boost: boost.tar.gz
+ tar -C .. -xvzf boost.tar.gz