summaryrefslogtreecommitdiff
path: root/qpid/cpp/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/configure.ac')
-rw-r--r--qpid/cpp/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/qpid/cpp/configure.ac b/qpid/cpp/configure.ac
index 43a32d3ad7..092694d56b 100644
--- a/qpid/cpp/configure.ac
+++ b/qpid/cpp/configure.ac
@@ -68,8 +68,10 @@ if test x$GXX = xyes; then
# The following warnings are deliberately omitted, they warn on valid code.
# -Wunreachable-code -Wpadded -Winline
# -Wshadow - warns about boost headers.
+ # Can't test for -Werror as whether it fails or not depends on what's in
+ # CFLAGS/CXXFLAGS. In any case it's been in gcc for a long time (since 2.95 at least)
if test "${enableval}" = yes; then
- gl_COMPILER_FLAGS(-Werror)
+ COMPILER_FLAGS="-Werror"
gl_COMPILER_FLAGS(-pedantic)
gl_COMPILER_FLAGS(-Wall)
gl_COMPILER_FLAGS(-Wextra)