summaryrefslogtreecommitdiff
path: root/qpid/cpp/docs/api/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/docs/api/Makefile.am')
-rw-r--r--qpid/cpp/docs/api/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/qpid/cpp/docs/api/Makefile.am b/qpid/cpp/docs/api/Makefile.am
new file mode 100644
index 0000000000..bde8b5fa3d
--- /dev/null
+++ b/qpid/cpp/docs/api/Makefile.am
@@ -0,0 +1,18 @@
+#
+# Run doxygen to generate HTML doc.
+# Generate dependency files so its rebuilt only when needed.
+#
+
+# TODO aconway 2007-04-12: html should have a
+# dependency on source/header files.
+
+EXTRA_DIST = html user.doxygen developer.doxygen html.timestamp
+
+html: html.timestamp
+
+html.timestamp:
+ doxygen user.doxygen
+ touch $@
+
+clean-local:
+ rm -rf html html-dev html.timestamp