summaryrefslogtreecommitdiff
path: root/qpid/cpp/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/src/CMakeLists.txt')
-rw-r--r--qpid/cpp/src/CMakeLists.txt76
1 files changed, 73 insertions, 3 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index b09309cb9c..733b4848f9 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -246,14 +246,47 @@ if (MSVC)
${_boost_regex_debug} ${_boost_regex_release}
${_boost_system_debug} ${_boost_system_release}
${_boost_thread_debug} ${_boost_thread_release}
- DESTINATION ${QPID_INSTALL_LIBDIR}
+ DESTINATION ${QPID_INSTALL_LIBDIR}/boost
COMPONENT ${QPID_COMPONENT_COMMON})
endif (QPID_LINK_BOOST_DYNAMIC)
- # Need the boost headers regardless of which way the libs go.
+ # Need the boost headers regardless of which way the libs go. Try to
+ # weed out what we don't need, else it's giant and unnecessary.
install (DIRECTORY ${Boost_INCLUDE_DIR}/boost
DESTINATION ${QPID_INSTALL_INCLUDEDIR}
- COMPONENT ${QPID_COMPONENT_CLIENT_INCLUDE})
+ COMPONENT ${QPID_COMPONENT_CLIENT_INCLUDE}
+ PATTERN "accumulators/*" EXCLUDE
+ PATTERN "algorithm/*" EXCLUDE
+ PATTERN "archive/*" EXCLUDE
+ PATTERN "asio*" EXCLUDE
+ PATTERN "bimap*" EXCLUDE
+ PATTERN "circular_buffer*" EXCLUDE
+ PATTERN "concept*" EXCLUDE
+ PATTERN "dynamic_bitset*" EXCLUDE
+ PATTERN "flyweight*" EXCLUDE
+ PATTERN "fusion*" EXCLUDE
+ PATTERN "gil*" EXCLUDE
+ PATTERN "graph*" EXCLUDE
+ PATTERN "interprocess*" EXCLUDE
+ PATTERN "lambda/*" EXCLUDE
+ PATTERN "logic*" EXCLUDE
+ PATTERN "math*" EXCLUDE
+ PATTERN "mpi*" EXCLUDE
+ PATTERN "multi_*" EXCLUDE
+ PATTERN "numeric*" EXCLUDE
+ PATTERN "pending*" EXCLUDE
+ PATTERN "pool*" EXCLUDE
+ PATTERN "property_map*" EXCLUDE
+ PATTERN "proto*" EXCLUDE
+ PATTERN "random*" EXCLUDE
+ PATTERN "range*" EXCLUDE
+ PATTERN "signals*" EXCLUDE
+ PATTERN "spirit*" EXCLUDE
+ PATTERN "statechart*" EXCLUDE
+ PATTERN "units*" EXCLUDE
+ PATTERN "unordered*" EXCLUDE
+ PATTERN "wave*" EXCLUDE
+ PATTERN "xpressive*" EXCLUDE)
set(Boost_DATE_TIME_LIBRARY "")
set(Boost_THREAD_LIBRARY "")
@@ -590,6 +623,19 @@ install (TARGETS qpidcommon
DESTINATION ${QPID_INSTALL_LIBDIR}
COMPONENT ${QPID_COMPONENT_COMMON})
+if (WIN32)
+ # Need the .pdb file, which isn't installed with the .dll/.lib
+ # Not built... if needed, add the build option then uncomment this.
+ #get_target_property(qpidcommon_dll qpidcommon LOCATION)
+ #string(REPLACE .dll .pdb qpidcommon_pdb ${qpidcommon_dll})
+ #string(REPLACE $(OutDir) \${CMAKE_INSTALL_CONFIG_NAME} qpidcommon_pdb ${qpidcommon_pdb})
+ #message(STATUS "_pdb: ${qpidcommon_pdb}")
+ #install (PROGRAMS
+ # ${qpidcommon_pdb}
+ # DESTINATION ${QPID_INSTALL_LIBDIR}
+ # COMPONENT ${QPID_COMPONENT_CLIENT})
+endif (WIN32)
+
set (qpidclient_SOURCES
${rgen_client_srcs}
${qpidclient_platform_SOURCES}
@@ -681,6 +727,7 @@ install (DIRECTORY ../include/qpid
DESTINATION ${QPID_INSTALL_INCLUDEDIR}
COMPONENT ${QPID_COMPONENT_CLIENT_INCLUDE}
PATTERN ".svn" EXCLUDE)
+
# Released source artifacts from Apache have the generated headers included in
# the source tree, not the binary tree. So don't attempt to grab them when
# they're not supposed to be there.
@@ -691,6 +738,18 @@ if (NOT QPID_GENERATED_HEADERS_IN_SOURCE)
endif (NOT QPID_GENERATED_HEADERS_IN_SOURCE)
if (WIN32)
+ # Need the .pdb file, which isn't installed with the .dll/.lib
+ #get_target_property(qpidclient_dll qpidclient LOCATION)
+ #string(REPLACE .dll .pdb qpidclient_pdb ${qpidclient_dll})
+ #string(REPLACE $(OutDir) \${CMAKE_INSTALL_CONFIG_NAME} qpidclient_pdb ${qpidclient_pdb})
+ #message(STATUS "_pdb: ${qpidclient_pdb}")
+ #install (PROGRAMS
+ # ${qpidclient_pdb}
+ # DESTINATION ${QPID_INSTALL_LIBDIR}
+ # COMPONENT ${QPID_COMPONENT_CLIENT})
+endif (WIN32)
+
+if (WIN32)
set(AMQP_WCF_DIR ${qpid-cpp_SOURCE_DIR}/../wcf)
set(DTC_PLUGIN_SOURCE ${AMQP_WCF_DIR}/src/Apache/Qpid/DtcPlugin/DtcPlugin.cpp)
if (EXISTS ${DTC_PLUGIN_SOURCE})
@@ -905,6 +964,17 @@ set_target_properties (qmfconsole PROPERTIES
install (TARGETS qmfconsole
DESTINATION ${QPID_INSTALL_LIBDIR}
COMPONENT ${QPID_COMPONENT_QMF})
+if (WIN32)
+ # Need the .pdb file, which isn't installed with the .dll/.lib
+ #get_target_property(qmfconsole_dll qmfconsole LOCATION)
+ #string(REPLACE .dll .pdb qmfconsole_pdb ${qmfconsole_dll})
+ #string(REPLACE $(OutDir) \${CMAKE_INSTALL_CONFIG_NAME} qmfconsole_pdb ${qmfconsole_pdb})
+ #message(STATUS "_pdb: ${qmfconsole_pdb}")
+ #install (PROGRAMS
+ # ${qmfconsole_pdb}
+ # DESTINATION ${QPID_INSTALL_LIBDIR}
+ # COMPONENT ${QPID_COMPONENT_QMF})
+endif (WIN32)
# A queue event listener plugin that creates messages on a replication
# queue corresponding to enqueue and dequeue events: