summaryrefslogtreecommitdiff
path: root/qpid/cpp/src/cluster.mk
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/src/cluster.mk')
-rw-r--r--qpid/cpp/src/cluster.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/qpid/cpp/src/cluster.mk b/qpid/cpp/src/cluster.mk
index 0d34788d2e..e2054d75e9 100644
--- a/qpid/cpp/src/cluster.mk
+++ b/qpid/cpp/src/cluster.mk
@@ -40,6 +40,8 @@ cluster_la_SOURCES = \
$(CMAN_SOURCES) \
qpid/cluster/Cluster.cpp \
qpid/cluster/Cluster.h \
+ qpid/cluster/Decoder.cpp \
+ qpid/cluster/Decoder.h \
qpid/cluster/PollableQueue.h \
qpid/cluster/ClusterMap.cpp \
qpid/cluster/ClusterMap.h \
@@ -49,14 +51,8 @@ cluster_la_SOURCES = \
qpid/cluster/Connection.h \
qpid/cluster/ConnectionCodec.cpp \
qpid/cluster/ConnectionCodec.h \
- qpid/cluster/ConnectionMap.h \
- qpid/cluster/ConnectionMap.cpp \
qpid/cluster/Cpg.cpp \
qpid/cluster/Cpg.h \
- qpid/cluster/Decoder.cpp \
- qpid/cluster/Decoder.h \
- qpid/cluster/ConnectionDecoder.cpp \
- qpid/cluster/ConnectionDecoder.h \
qpid/cluster/Dispatchable.h \
qpid/cluster/UpdateClient.cpp \
qpid/cluster/UpdateClient.h \
@@ -68,8 +64,11 @@ cluster_la_SOURCES = \
qpid/cluster/ExpiryPolicy.cpp \
qpid/cluster/FailoverExchange.cpp \
qpid/cluster/FailoverExchange.h \
+ qpid/cluster/UpdateExchange.h \
+ qpid/cluster/LockedConnectionMap.h \
qpid/cluster/Multicaster.cpp \
qpid/cluster/Multicaster.h \
+ qpid/cluster/McastFrameHandler.h \
qpid/cluster/NoOpConnectionOutputHandler.h \
qpid/cluster/OutputInterceptor.cpp \
qpid/cluster/OutputInterceptor.h \