summaryrefslogtreecommitdiff
path: root/qpid/cpp/src/cluster.mk
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/src/cluster.mk')
-rw-r--r--qpid/cpp/src/cluster.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/qpid/cpp/src/cluster.mk b/qpid/cpp/src/cluster.mk
new file mode 100644
index 0000000000..9503845b92
--- /dev/null
+++ b/qpid/cpp/src/cluster.mk
@@ -0,0 +1,24 @@
+#
+# Cluster library makefile fragment, to be included in Makefile.am
+#
+lib_LTLIBRARIES += libqpidcluster.la
+
+if CPG
+
+libqpidcluster_la_SOURCES = \
+ qpid/cluster/Cluster.cpp \
+ qpid/cluster/Cluster.h \
+ qpid/cluster/Cpg.cpp \
+ qpid/cluster/Cpg.h \
+ qpid/cluster/Dispatchable.h \
+ qpid/cluster/ClusterPlugin.cpp \
+ qpid/cluster/ClassifierHandler.h \
+ qpid/cluster/ClassifierHandler.cpp
+
+libqpidcluster_la_LIBADD= -lcpg libqpidbroker.la
+
+else
+# Empty stub library to satisfy rpm spec file.
+libqpidcluster_la_SOURCES =
+
+endif