summaryrefslogtreecommitdiff
path: root/qpid/cpp/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/tests/Makefile.am')
-rw-r--r--qpid/cpp/tests/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/qpid/cpp/tests/Makefile.am b/qpid/cpp/tests/Makefile.am
index e52a3512f0..1aab82c307 100644
--- a/qpid/cpp/tests/Makefile.am
+++ b/qpid/cpp/tests/Makefile.am
@@ -70,11 +70,10 @@ check: run-unit-tests run-python-tests
run-unit-tests: $(check_LTLIBRARIES)
DllPlugInTester -c -b .libs/*.so
-# TODO aconway 2006-12-01: Should also check for qpidd.
-run-python-tests: $(check_LTLIBRARIES)
- ../src/qpidd > qpidd.log 2>&1 &
+run-python-tests: $(check_LTLIBRARIES) ../src/qpidd
+ ../src/qpidd > qpidd.log 2>&1 & echo $$! > qpidd.pid
cd ../../python ; ./run-tests -v -I cpp_failing.txt
-
+ kill `cat qpidd.pid`
include gen.mk