summaryrefslogtreecommitdiff
path: root/trunk/qpid/cpp/docs/api/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/qpid/cpp/docs/api/Makefile.am')
-rw-r--r--trunk/qpid/cpp/docs/api/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/trunk/qpid/cpp/docs/api/Makefile.am b/trunk/qpid/cpp/docs/api/Makefile.am
new file mode 100644
index 0000000000..3b9c7648e0
--- /dev/null
+++ b/trunk/qpid/cpp/docs/api/Makefile.am
@@ -0,0 +1,22 @@
+#
+# Run doxygen to generate HTML doc.
+# Generate dependency files so its rebuilt only when needed.
+#
+
+# TODO aconway 2007-04-12: html should have a
+# dependency on source/header files.
+
+if HAVE_DOXYGEN
+
+EXTRA_DIST = html user.doxygen developer.doxygen html.timestamp
+
+html: html.timestamp
+
+html.timestamp:
+ doxygen user.doxygen
+ touch $@
+
+clean-local:
+ rm -rf html html-dev html.timestamp
+
+endif