summaryrefslogtreecommitdiff
path: root/trunk/qpid/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/qpid/python/setup.py')
-rw-r--r--trunk/qpid/python/setup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/trunk/qpid/python/setup.py b/trunk/qpid/python/setup.py
new file mode 100644
index 0000000000..be8c7c2a03
--- /dev/null
+++ b/trunk/qpid/python/setup.py
@@ -0,0 +1,25 @@
+#!/usr/bin/env python
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+from distutils.core import setup
+
+setup(name="qpid", version="0.6", packages=["qpid", "mllib"], scripts=["amqp-doc"],
+ url="http://qpid.apache.org/",
+ license="Apache Software License",
+ description="Python language client implementation for Apache Qpid")