summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2017-10-10 23:52:48 -0700
committerAlan Antonuk <alan.antonuk@gmail.com>2017-10-10 23:52:48 -0700
commit725fe3711071aa153a356c9e93d354dc61309e3c (patch)
tree04465a1f943e8f259d36d43634e7273aed543e94
parent5876a8e9b2e1b57e802f7ac5daa17ab2f24d2ae0 (diff)
downloadrabbitmq-c-725fe3711071aa153a356c9e93d354dc61309e3c.tar.gz
build: remove autotools build system
CMake based system works on the 3 platforms that we target, and maintaining a parallel build-system isn't worth it for this sized project.
-rw-r--r--.travis.yml3
-rw-r--r--Makefile.am401
-rw-r--r--configure.ac203
-rw-r--r--m4/.gitignore5
-rw-r--r--m4/ax_have_poll.m472
-rw-r--r--m4/ax_have_select.m471
-rw-r--r--m4/ax_python_module.m449
-rw-r--r--m4/cflags.m459
-rw-r--r--m4/ldflags.m458
-rw-r--r--m4/popt.m473
-rwxr-xr-xtravis.sh9
11 files changed, 1 insertions, 1002 deletions
diff --git a/.travis.yml b/.travis.yml
index 634f4ee..1e9396f 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -19,9 +19,6 @@ matrix:
# coverity_scan branch hack below works correctly.
- compiler: gcc
os: linux
- env: CONFIG=autotools
- - compiler: gcc
- os: linux
env: CONFIG=cmake
- compiler: clang
os: linux
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index 014e5ac..0000000
--- a/Makefile.am
+++ /dev/null
@@ -1,401 +0,0 @@
-# vim:set ts=2 sw=2 sts=2 noet:
-ACLOCAL_AMFLAGS = -I m4
-
-AM_CFLAGS = -I$(top_srcdir)/librabbitmq
-
-lib_LTLIBRARIES = librabbitmq/librabbitmq.la
-
-librabbitmq_librabbitmq_la_CFLAGS = \
- $(SSL_CFLAGS) \
- $(AM_CFLAGS)
-
-librabbitmq_librabbitmq_la_LDFLAGS = \
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
- $(NO_UNDEFINED) \
- $(SSL_LIBS)
-
-include_HEADERS = \
- librabbitmq/amqp.h \
- librabbitmq/amqp_framing.h \
- librabbitmq/amqp_tcp_socket.h
-
-if SSL
-include_HEADERS += librabbitmq/amqp_ssl_socket.h
-endif
-
-librabbitmq_librabbitmq_la_SOURCES = \
- librabbitmq/amqp_api.c \
- librabbitmq/amqp_connection.c \
- librabbitmq/amqp_consumer.c \
- librabbitmq/amqp_framing.c \
- librabbitmq/amqp_mem.c \
- librabbitmq/amqp_private.h \
- librabbitmq/amqp_socket.c \
- librabbitmq/amqp_socket.h \
- librabbitmq/amqp_table.c \
- librabbitmq/amqp_table.h \
- librabbitmq/amqp_tcp_socket.c \
- librabbitmq/amqp_tcp_socket.h \
- librabbitmq/amqp_time.c \
- librabbitmq/amqp_time.h \
- librabbitmq/amqp_url.c
-
-if SSL_OPENSSL
-librabbitmq_librabbitmq_la_SOURCES += \
- librabbitmq/amqp_hostcheck.c \
- librabbitmq/amqp_hostcheck.h \
- librabbitmq/amqp_openssl.c \
- librabbitmq/amqp_openssl_bio.c \
- librabbitmq/amqp_openssl_bio.h \
- librabbitmq/amqp_openssl_hostname_validation.c \
- librabbitmq/amqp_openssl_hostname_validation.h
-
-librabbitmq_librabbitmq_la_LDFLAGS += -pthread
-
-if OS_APPLE
-librabbitmq_librabbitmq_la_CFLAGS += -Wno-deprecated-declarations
-endif
-endif
-
-if OS_UNIX
-librabbitmq_librabbitmq_la_SOURCES += librabbitmq/unix/threads.h
-librabbitmq_librabbitmq_la_CFLAGS += -I$(top_srcdir)/librabbitmq/unix
-endif
-
-if OS_WIN32
-librabbitmq_librabbitmq_la_SOURCES += librabbitmq/win32/threads.h
-librabbitmq_librabbitmq_la_CFLAGS += \
- -I$(top_srcdir)/librabbitmq/win32 \
- -I$(top_srcdir)/librabbitmq/win32/msinttypes
-endif
-
-
-check_PROGRAMS = \
- tests/test_tables \
- tests/test_parse_url \
- tests/test_hostcheck \
- tests/test_status_enum \
- tests/test_sasl_mechanism \
- tests/test_merge_capabilities
-
-TESTS = $(check_PROGRAMS)
-
-tests_test_tables_SOURCES = tests/test_tables.c
-tests_test_tables_LDADD = librabbitmq/librabbitmq.a
-
-tests_test_parse_url_SOURCES = tests/test_parse_url.c
-tests_test_parse_url_LDADD = librabbitmq/librabbitmq.a
-
-tests_test_hostcheck_SOURCES = \
- tests/test_hostcheck.c \
- librabbitmq/amqp_hostcheck.c
-
-tests_test_status_enum_SOURCES = tests/test_status_enum.c
-tests_test_status_enum_LDADD = librabbitmq/librabbitmq.a
-
-tests_test_sasl_mechanism_SOURCES = tests/test_sasl_mechanism.c
-tests_test_sasl_mechanism_LDADD = librabbitmq/librabbitmq.a
-
-tests_test_merge_capabilities_SOURCES = tests/test_merge_capabilities.c
-tests_test_merge_capabilities_LDADD = librabbitmq/librabbitmq.a
-
-noinst_LTLIBRARIES =
-
-if EXAMPLES
-noinst_LTLIBRARIES += examples/libutils.la
-
-examples_libutils_la_SOURCES = \
- examples/utils.c \
- examples/utils.h
-examples_libutils_la_CFLAGS = $(AM_CFLAGS)
-
-if OS_UNIX
-examples_libutils_la_SOURCES += examples/unix/platform_utils.c
-endif
-
-if OS_WIN32
-examples_libutils_la_SOURCES += examples/win32/platform_utils.c
-examples_libutils_la_CFLAGS += -I$(top_srcdir)/tools/win32/msinttypes
-endif
-
-noinst_PROGRAMS = \
- examples/amqp_bind \
- examples/amqp_consumer \
- examples/amqp_connect_timeout \
- examples/amqp_exchange_declare \
- examples/amqp_listen \
- examples/amqp_listenq \
- examples/amqp_producer \
- examples/amqp_rpc_sendstring_client \
- examples/amqp_sendstring \
- examples/amqp_unbind
-
-examples_amqp_sendstring_SOURCES = examples/amqp_sendstring.c
-examples_amqp_sendstring_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqp_exchange_declare_SOURCES = examples/amqp_exchange_declare.c
-examples_amqp_exchange_declare_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqp_listen_SOURCES = examples/amqp_listen.c
-examples_amqp_listen_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqp_producer_SOURCES = examples/amqp_producer.c
-examples_amqp_producer_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqp_consumer_SOURCES = examples/amqp_consumer.c
-examples_amqp_consumer_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqp_connect_timeout_SOURCES = examples/amqp_connect_timeout.c
-examples_amqp_connect_timeout_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqp_unbind_SOURCES = examples/amqp_unbind.c
-examples_amqp_unbind_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqp_bind_SOURCES = examples/amqp_bind.c
-examples_amqp_bind_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqp_listenq_SOURCES = examples/amqp_listenq.c
-examples_amqp_listenq_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqp_rpc_sendstring_client_SOURCES = \
- examples/amqp_rpc_sendstring_client.c
-examples_amqp_rpc_sendstring_client_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-if SSL
-noinst_PROGRAMS += \
- examples/amqps_bind \
- examples/amqps_connect_timeout \
- examples/amqps_consumer \
- examples/amqps_exchange_declare \
- examples/amqps_listen \
- examples/amqps_listenq \
- examples/amqps_producer \
- examples/amqps_sendstring \
- examples/amqps_unbind
-
-examples_amqps_bind_SOURCES = examples/amqps_bind.c
-examples_amqps_bind_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqps_connect_timeout_SOURCES = examples/amqps_connect_timeout.c
-examples_amqps_connect_timeout_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqps_consumer_SOURCES = examples/amqps_consumer.c
-examples_amqps_consumer_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqps_exchange_declare_SOURCES = examples/amqps_exchange_declare.c
-examples_amqps_exchange_declare_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqps_listen_SOURCES = examples/amqps_listen.c
-examples_amqps_listen_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqps_listenq_SOURCES = examples/amqps_listenq.c
-examples_amqps_listenq_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqps_producer_SOURCES = examples/amqps_producer.c
-examples_amqps_producer_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqps_sendstring_SOURCES = examples/amqps_sendstring.c
-examples_amqps_sendstring_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-
-examples_amqps_unbind_SOURCES = examples/amqps_unbind.c
-examples_amqps_unbind_LDADD = \
- examples/libutils.la \
- librabbitmq/librabbitmq.la
-endif
-endif
-
-if TOOLS
-noinst_LTLIBRARIES += tools/libcommon.la
-
-tools_libcommon_la_SOURCES = \
- tools/common.c \
- tools/common.h
-tools_libcommon_la_CFLAGS = \
- $(AM_CFLAGS) \
- -I$(top_srcdir)/tools
-
-tools_platform_CFLAGS = $(AM_CFLAGS)
-
-if OS_UNIX
-tools_libcommon_la_SOURCES += \
- tools/unix/process.c \
- tools/unix/process.h
-tools_platform_CFLAGS += -I$(top_srcdir)/tools/unix
-endif
-
-if OS_WIN32
-tools_libcommon_la_SOURCES += \
- tools/win32/compat.c \
- tools/win32/compat.h \
- tools/win32/process.c \
- tools/win32/process.h
-tools_platform_CFLAGS += \
- -I$(top_srcdir)/tools/win32 \
- -I$(top_srcdir)/tools/win32/msinttypes
-endif
-
-bin_PROGRAMS = \
- tools/amqp-consume \
- tools/amqp-declare-queue \
- tools/amqp-delete-queue \
- tools/amqp-get \
- tools/amqp-publish
-
-tools_amqp_publish_SOURCES = tools/publish.c
-tools_amqp_publish_CFLAGS = \
- $(AM_CFLAGS) \
- $(POPT_CFLAGS) \
- $(tools_platform_CFLAGS) \
- -I$(top_srcdir)/tools
-tools_amqp_publish_LDADD = \
- $(POPT_LIBS) \
- tools/libcommon.la \
- librabbitmq/librabbitmq.la
-
-tools_amqp_get_SOURCES = tools/get.c
-tools_amqp_get_CFLAGS = \
- $(AM_CFLAGS) \
- $(POPT_CFLAGS) \
- $(tools_platform_CFLAGS) \
- -I$(top_srcdir)/tools
-tools_amqp_get_LDADD = \
- $(POPT_LIBS) \
- tools/libcommon.la \
- librabbitmq/librabbitmq.la
-
-tools_amqp_consume_SOURCES = tools/consume.c
-tools_amqp_consume_CFLAGS = \
- $(AM_CFLAGS) \
- $(POPT_CFLAGS) \
- $(tools_platform_CFLAGS) \
- -I$(top_srcdir)/tools
-tools_amqp_consume_LDADD = \
- $(POPT_LIBS) \
- tools/libcommon.la \
- librabbitmq/librabbitmq.la
-
-tools_amqp_declare_queue_SOURCES = tools/declare_queue.c
-tools_amqp_declare_queue_CFLAGS = \
- $(AM_CFLAGS) \
- $(POPT_CFLAGS) \
- $(tools_platform_CFLAGS) \
- -I$(top_srcdir)/tools
-tools_amqp_declare_queue_LDADD = \
- $(POPT_LIBS) \
- tools/libcommon.la \
- librabbitmq/librabbitmq.la
-
-tools_amqp_delete_queue_SOURCES = tools/delete_queue.c
-tools_amqp_delete_queue_CFLAGS = \
- $(AM_CFLAGS) \
- $(POPT_CFLAGS) \
- $(tools_platform_CFLAGS) \
- -I$(top_srcdir)/tools
-tools_amqp_delete_queue_LDADD = \
- $(POPT_LIBS) \
- tools/libcommon.la \
- librabbitmq/librabbitmq.la
-
-if DOCS
-man_MANS = \
- $(top_builddir)/tools/doc/amqp-publish.1 \
- $(top_builddir)/tools/doc/amqp-consume.1 \
- $(top_builddir)/tools/doc/amqp-get.1 \
- $(top_builddir)/tools/doc/amqp-declare-queue.1 \
- $(top_builddir)/tools/doc/amqp-delete-queue.1 \
- $(top_builddir)/tools/doc/librabbitmq-tools.7
-
-# xmlto's --searchpath doesn't get passed through to xmllint, so we disable
-# xmllint validation with --skip-validation for the benefit of build/source
-# separation as required by distcheck, debian packaging etc.
-XMLTO_FLAGS = \
- --skip-validation \
- --searchpath $(abs_top_builddir)/tools/doc
-
-%.1: %.xml $(top_builddir)/tools/doc/man-date.ent
- $(AM_V_GEN)$(XMLTO) $(XMLTO_FLAGS) -o $(top_builddir)/tools/doc man $<
-
-%.7: %.xml $(top_builddir)/tools/doc/man-date.ent
- $(AM_V_GEN)$(XMLTO) $(XMLTO_FLAGS) -o $(top_builddir)/tools/doc man $<
-
-$(top_builddir)/tools/doc/man-date.ent:
- $(AM_V_at)$(MKDIR_P) $(top_builddir)/tools/doc
- $(AM_V_GEN)date +'%Y-%m-%d' > $@
-endif # DOCS
-endif # TOOLS
-
-EXTRA_DIST = \
- AUTHORS \
- CMakeLists.txt \
- CONTRIBUTING.md \
- ChangeLog.md \
- LICENSE-MIT \
- README.md \
- THANKS \
- TODO \
- cmake \
- codegen \
- docs \
- examples/CMakeLists.txt \
- librabbitmq/CMakeLists.txt \
- librabbitmq/codegen.py \
- librabbitmq/win32 \
- tests/CMakeLists.txt \
- tests/test_tables.expected \
- tests/win32 \
- tools/CMakeLists.txt \
- tools/doc/amqp-consume.xml \
- tools/doc/amqp-declare-queue.xml \
- tools/doc/amqp-delete-queue.xml \
- tools/doc/amqp-get.xml \
- tools/doc/amqp-publish.xml \
- tools/doc/librabbitmq-tools.xml
-
-MOSTLYCLEANFILES = \
- $(man_MANS) \
- $(top_builddir)/tools/doc/man-date.ent
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = librabbitmq.pc
-
-clean-local:
- -$(MAKE) -C codegen clean
-
-distclean-local:
- -$(MAKE) -C codegen distclean
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index 16f5eef..0000000
--- a/configure.ac
+++ /dev/null
@@ -1,203 +0,0 @@
-# vim:set ts=2 sw=2 sts=2 et:
-AC_PREREQ([2.59])
-
-m4_define([major_version], [0])
-m4_define([minor_version], [8])
-m4_define([micro_version], [1])
-
-# Follow all steps below in order to calculate new ABI version when updating the library
-# NOTE: THIS IS UNRELATED to the actual project version
-#
-# 1. If the library source code has changed at all since the last update, then increment revision
-# 2. If any interfaces have been added, removed, or changed since the last update, increment current and set revision to 0.
-# 3. If any interfaces have been added since the last public release, then increment age.
-# 4. If any interfaces have been removed since the last public release, then set age to 0.
-m4_define([soversion_current], [6])
-m4_define([soversion_revision], [1])
-m4_define([soversion_age], [2])
-
-AC_INIT([rabbitmq-c], [major_version.minor_version.micro_version],
- [https://github.com/alanxz/rabbitmq-c/issues], [rabbitmq-c],
- [http://www.rabbitmq.com/])
-AC_CONFIG_MACRO_DIR([m4])
-AM_INIT_AUTOMAKE([1.9 subdir-objects foreign -Wno-portability])
-m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-AC_CONFIG_SRCDIR([librabbitmq/amqp.h])
-AC_GNU_SOURCE
-
-# Initialize Libtool
-LT_PREREQ([2.2])
-LT_INIT([disable-static win32-dll])
-
-# Program checks
-m4_ifdef([AC_PROG_CC_89], [AC_PROG_CC_89],
- [AC_MSG_WARN([Attempt c89 workaround for old versions of autoconf])
- AC_PROG_CC
- AX_TRY_CFLAGS([-std=gnu90], [AX_CFLAGS([-std=gnu90])])])
-PKG_PROG_PKG_CONFIG([0.17])
-
-# Environment setup
-AC_CANONICAL_HOST
-AC_C_INLINE
-
-# Set compiler flags
-AX_TRY_CFLAGS([-Wall], [AX_CFLAGS([-Wall])])
-AX_TRY_CFLAGS([-Wextra], [AX_CFLAGS([-Wextra])])
-AX_TRY_CFLAGS([-Wstrict-prototypes], [AX_CFLAGS([-Wstrict-prototypes])])
-AX_TRY_CFLAGS([-Wno-unused-function], [AX_CFLAGS([-Wno-unused-function])])
-AX_TRY_CFLAGS([-fno-common], [AX_CFLAGS([-fno-common])])
-AX_TRY_CFLAGS([-fvisibility=hidden], [AX_CFLAGS([-fvisibility=hidden])])
-AX_TRY_LDFLAGS([-no-undefined], [NO_UNDEFINED=-no-undefined])
-AC_SUBST([NO_UNDEFINED])
-
-# Libtool versioning
-LT_CURRENT=soversion_current
-LT_REVISION=soversion_revision
-LT_AGE=soversion_age
-AC_SUBST([LT_CURRENT])
-AC_SUBST([LT_REVISION])
-AC_SUBST([LT_AGE])
-
-# OS setup
-os_unix=no
-os_apple=no
-os_win32=no
-AS_CASE([$host],
- [*-*-mingw*],
- [os_win32=yes],
- [*-apple-darwin*],
- [os_apple=yes; os_unix=yes],
- [*],
- [os_unix=yes])
-AM_CONDITIONAL([OS_UNIX], [test "x$os_unix" = xyes])
-AM_CONDITIONAL([OS_APPLE], [test "x$os_apple" = xyes])
-AM_CONDITIONAL([OS_WIN32], [test "x$os_win32" = xyes])
-AC_DEFINE([ENABLE_THREAD_SAFETY], [1], [Define to 1 to enable thread safety])
-
-# Extra Win32 setup
-AS_IF([test "x$os_win32" = xyes],
- [AC_DEFINE([OS_WIN32], [1], [Define to 1 for Win32.])
- AC_DEFINE([AMQP_BUILD], [1], [Define to 1 for a Win32 build.])
- AS_IF([test "x$GCC" = xyes],
- [AX_LDFLAGS([-lws2_32])],
- [AX_LDFLAGS([ws2_32.lib])])
- AS_IF([test "x$enable_static" = "xyes"],
- [AS_IF([test "x$enable_shared" = "xyes"],
- [AC_MSG_ERROR([select one of shared @<:@--enable-shared@:>@ or static @<:@--enable-static@:>@.])],
- [AC_DEFINE([AMQP_STATIC], [1],
- [Define to 1 for a static Win32 build.])])])])
-
-# Detect which libraries we might need to use socket functions:
-# Solaris needs -lsocket -lnsl
-# QNX will need -lsocket
-
-saved_CFLAGS=$CFLAGS
-CFLAGS=
-AC_SEARCH_LIBS([getaddrinfo], [socket], [],
- [AC_CHECK_LIB([getaddrinfo], [socket],
- [LIBS="-lsocket -lnsl $LIBS"],
- [AC_MSG_ERROR([cannot find name resolution library (library with getaddrinfo symbol)])],
- [-lnsl])])
-AC_SEARCH_LIBS([socket], [socket], [],
- [AC_CHECK_LIB([socket], [socket],
- [LIBS="-lsocket -lnsl $LIBS"],
- [AC_MSG_ERROR([cannot find socket library (library with socket symbol)])],
- [-lnsl])])
-AC_SEARCH_LIBS([clock_gettime], [rt])
-AC_SEARCH_LIBS([posix_spawnp], [rt])
-AC_MSG_CHECKING([if htonll is defined])
-
-dnl # Check for htonll
-AC_LINK_IFELSE(
- [AC_LANG_PROGRAM(
- [[
- #include <arpa/inet.h>
- ]],
- [[
- return htonll(0);
- ]]
- )],
- [
- AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_HTONLL, 1, [Define to 1 if the function (or macro) htonll exists.])
- ],
- [
- AC_MSG_RESULT(no)
- ]
-)
-
-# Need poll() or select()
-AX_HAVE_POLL([AC_DEFINE([HAVE_POLL], [], ["Have poll()"])],
- AX_HAVE_SELECT([AC_DEFINE([HAVE_SELECT], [], ["Have select()"])],
- [AC_MSG_ERROR([rabbitmq-c needs poll() or select()])]))
-
-# Configure SSL/TLS
-AC_ARG_WITH([ssl],
- [AS_HELP_STRING([--with-ssl=@<:@no/openssl/yes@:>@],
- [enable SSL/TLS support @<:@default=openssl@:>@])],
- [AS_CASE([$withval],
- [yes], [with_ssl=openssl],
- [*], [with_ssl=$withval])],
- [with_ssl=openssl])
-
-AS_IF([test "x$with_ssl" = "xopenssl"],
- [PKG_CHECK_MODULES([SSL], [openssl >= 0.9.8], [ssl_pkg_required=openssl],
- [with_ssl=no])],
- [test "x$with_ssl" = "xno"],,
- [AC_MSG_ERROR([unknown SSL/TLS implementation: $with_ssl])])
-AM_CONDITIONAL([SSL_OPENSSL], [test "x$with_ssl" = "xopenssl"])
-AM_CONDITIONAL([SSL], [test "x$with_ssl" != "xno"])
-AS_IF([test "x$with_ssl" != "xno"],
- [AC_DEFINE([WITH_SSL], [1], [Define to 1 if SSL/TLS is enabled.])])
-
-# Configure AMQP command-line tools
-AC_ARG_ENABLE([tools],
- [AS_HELP_STRING([--enable-tools],
- [build AMQP command-line tools @<:@auto@:>@])],,
- [enable_tools=auto])
-AS_IF([test "x$enable_tools" != "xno"],
- [AX_LIB_POPT([enable_tools=yes], [enable_tools=no])])
-AM_CONDITIONAL([TOOLS], [test "x$enable_tools" = "xyes"])
-
-# Configure command-line tool documentation
-AC_ARG_ENABLE([docs],
- [AS_HELP_STRING([--enable-docs],
- [build command-line tool documentation @<:@auto@:>@])],,
- [AS_IF([test "x$enable_tools" = "xno"],
- [enable_docs=no],
- [enable_docs=auto])])
-AC_ARG_VAR([XMLTO], [xmlto command])
-AS_IF([test "x$enable_docs" != "xno"],
- [AS_IF([test "x$XMLTO" = "x"],
- [AC_CHECK_PROGS([XMLTO], [xmlto])])
- AS_IF([test "x$XMLTO" != "x"],
- [enable_docs=yes],
- [enable_docs=no])])
-AM_CONDITIONAL([DOCS], [test "x$enable_docs" = "xyes"])
-
-# Configure examples
-AC_ARG_ENABLE([examples],
- [AS_HELP_STRING([--enable-examples],
- [build example code @<:@auto@:>@])],,
- [enable_examples=yes])
-AM_CONDITIONAL([EXAMPLES], [test "x$enable_examples" = "xyes"])
-
-AC_SUBST([requires_private], [$ssl_pkg_required])
-AC_SUBST([libs_private], [$LIBS])
-AC_DEFINE_UNQUOTED([AMQ_PLATFORM], ["$host_os"], [Host operating system string])
-AC_CONFIG_HEADERS([config.h])
-AC_CONFIG_FILES([
- librabbitmq.pc
- Makefile
-])
-CFLAGS=$saved_CFLAGS
-AC_OUTPUT
-AC_MSG_RESULT([
-$PACKAGE_NAME build options:
- Host: $host
- Version: $VERSION
- SSL/TLS: $with_ssl
- Tools: $enable_tools
- Documentation: $enable_docs
- Examples: $enable_examples
-])
diff --git a/m4/.gitignore b/m4/.gitignore
deleted file mode 100644
index 38066dd..0000000
--- a/m4/.gitignore
+++ /dev/null
@@ -1,5 +0,0 @@
-libtool.m4
-ltoptions.m4
-ltsugar.m4
-ltversion.m4
-lt~obsolete.m4
diff --git a/m4/ax_have_poll.m4 b/m4/ax_have_poll.m4
deleted file mode 100644
index 14d3d4b..0000000
--- a/m4/ax_have_poll.m4
+++ /dev/null
@@ -1,72 +0,0 @@
-# ===========================================================================
-# http://www.gnu.org/software/autoconf-archive/ax_have_poll.html
-# ===========================================================================
-#
-# SYNOPSIS
-#
-# AX_HAVE_POLL([ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
-# AX_HAVE_PPOLL([ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
-#
-# DESCRIPTION
-#
-# This macro determines whether the system supports the poll I/O event
-# interface. A neat usage example would be:
-#
-# AX_HAVE_POLL(
-# [AX_CONFIG_FEATURE_ENABLE(poll)],
-# [AX_CONFIG_FEATURE_DISABLE(poll)])
-# AX_CONFIG_FEATURE(
-# [poll], [This platform supports poll(7)],
-# [HAVE_POLL], [This platform supports poll(7).])
-#
-# Some systems -- most notably Linux kernel 2.6.16 and later -- also have
-# the variant ppoll(). The availability of that function can be tested
-# with the second macro. Generally speaking, it is safe to assume that
-# AX_HAVE_POLL would succeed if AX_HAVE_PPOLL has, but not the other way
-# round.
-#
-# LICENSE
-#
-# Copyright (c) 2009 Peter Simons <simons@cryp.to>
-#
-# Copying and distribution of this file, with or without modification, are
-# permitted in any medium without royalty provided the copyright notice
-# and this notice are preserved. This file is offered as-is, without any
-# warranty.
-
-#serial 7
-
-AC_DEFUN([AX_HAVE_POLL], [dnl
- AC_MSG_CHECKING([for poll(2)])
- AC_CACHE_VAL([ax_cv_have_poll], [dnl
- AC_LINK_IFELSE([dnl
- AC_LANG_PROGRAM(
- [#include <poll.h>],
- [int rc; rc = poll((struct pollfd *)(0), 0, 0);])],
- [ax_cv_have_poll=yes],
- [ax_cv_have_poll=no])])
- AS_IF([test "${ax_cv_have_poll}" = "yes"],
- [AC_MSG_RESULT([yes])
-$1],[AC_MSG_RESULT([no])
-$2])
-])dnl
-
-AC_DEFUN([AX_HAVE_PPOLL], [dnl
- AC_MSG_CHECKING([for ppoll(2)])
- AC_CACHE_VAL([ax_cv_have_ppoll], [dnl
- AC_LINK_IFELSE([dnl
- AC_LANG_PROGRAM(
- [dnl
-#include <poll.h>
-#include <signal.h>],
- [dnl
-int rc;
-rc = poll((struct pollfd *)(0), 0, 0);
-rc = ppoll((struct pollfd *)(0), 0, (struct timespec const *)(0), (sigset_t const *)(0));])],
- [ax_cv_have_ppoll=yes],
- [ax_cv_have_ppoll=no])])
- AS_IF([test "${ax_cv_have_ppoll}" = "yes"],
- [AC_MSG_RESULT([yes])
-$1],[AC_MSG_RESULT([no])
-$2])
-])
diff --git a/m4/ax_have_select.m4 b/m4/ax_have_select.m4
deleted file mode 100644
index 4024212..0000000
--- a/m4/ax_have_select.m4
+++ /dev/null
@@ -1,71 +0,0 @@
-# ===========================================================================
-# http://www.gnu.org/software/autoconf-archive/ax_have_select.html
-# ===========================================================================
-#
-# SYNOPSIS
-#
-# AX_HAVE_SELECT([ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
-# AX_HAVE_PSELECT([ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
-#
-# DESCRIPTION
-#
-# This macro determines whether the system supports the select I/O event
-# interface. A neat usage example would be:
-#
-# AX_HAVE_SELECT(
-# [AX_CONFIG_FEATURE_ENABLE(select)],
-# [AX_CONFIG_FEATURE_DISABLE(select)])
-# AX_CONFIG_FEATURE(
-# [select], [This platform supports select(7)],
-# [HAVE_SELECT], [This platform supports select(7).])
-#
-# Some systems also have the variant pselect(). The availability of that
-# function can be tested with the second macro. Generally speaking, it is
-# safe to assume that AX_HAVE_SELECT would succeed if AX_HAVE_SELECT_PWAIT
-# has, but not the other way round.
-#
-# LICENSE
-#
-# Copyright (c) 2009 Peter Simons <simons@cryp.to>
-#
-# Copying and distribution of this file, with or without modification, are
-# permitted in any medium without royalty provided the copyright notice
-# and this notice are preserved. This file is offered as-is, without any
-# warranty.
-
-#serial 7
-
-AC_DEFUN([AX_HAVE_SELECT], [dnl
- AC_MSG_CHECKING([for select(2)])
- AC_CACHE_VAL([ax_cv_have_select], [dnl
- AC_LINK_IFELSE([dnl
- AC_LANG_PROGRAM(
- [#include <sys/select.h>],
- [int rc; rc = select(0, (fd_set *)(0), (fd_set *)(0), (fd_set *)(0), (struct timeval *)(0));])],
- [ax_cv_have_select=yes],
- [ax_cv_have_select=no])])
- AS_IF([test "${ax_cv_have_select}" = "yes"],
- [AC_MSG_RESULT([yes])
-$1],[AC_MSG_RESULT([no])
-$2])
-])dnl
-
-AC_DEFUN([AX_HAVE_PSELECT], [dnl
- AC_MSG_CHECKING([for pselect(2)])
- AC_CACHE_VAL([ax_cv_have_pselect], [dnl
- AC_LINK_IFELSE([dnl
- AC_LANG_PROGRAM(
- [dnl
-#include <sys/select.h>
-#include <signal.h>],
- [dnl
-int rc;
-rc = select(0, (fd_set *)(0), (fd_set *)(0), (fd_set *)(0), (struct timeval *)(0));
-rc = pselect(0, (fd_set *)(0), (fd_set *)(0), (fd_set *)(0), (struct timespec const *)(0), (sigset_t const *)(0));])],
- [ax_cv_have_pselect=yes],
- [ax_cv_have_pselect=no])])
- AS_IF([test "${ax_cv_have_pselect}" = "yes"],
- [AC_MSG_RESULT([yes])
-$1],[AC_MSG_RESULT([no])
-$2])
-])dnl
diff --git a/m4/ax_python_module.m4 b/m4/ax_python_module.m4
deleted file mode 100644
index bd70a06..0000000
--- a/m4/ax_python_module.m4
+++ /dev/null
@@ -1,49 +0,0 @@
-# ===========================================================================
-# http://www.gnu.org/software/autoconf-archive/ax_python_module.html
-# ===========================================================================
-#
-# SYNOPSIS
-#
-# AX_PYTHON_MODULE(modname[, fatal])
-#
-# DESCRIPTION
-#
-# Checks for Python module.
-#
-# If fatal is non-empty then absence of a module will trigger an error.
-#
-# LICENSE
-#
-# Copyright (c) 2008 Andrew Collier <colliera@ukzn.ac.za>
-#
-# Copying and distribution of this file, with or without modification, are
-# permitted in any medium without royalty provided the copyright notice
-# and this notice are preserved. This file is offered as-is, without any
-# warranty.
-
-#serial 5
-
-AU_ALIAS([AC_PYTHON_MODULE], [AX_PYTHON_MODULE])
-AC_DEFUN([AX_PYTHON_MODULE],[
- if test -z $PYTHON;
- then
- PYTHON="python"
- fi
- PYTHON_NAME=`basename $PYTHON`
- AC_MSG_CHECKING($PYTHON_NAME module: $1)
- $PYTHON -c "import $1" 2>/dev/null
- if test $? -eq 0;
- then
- AC_MSG_RESULT(yes)
- eval AS_TR_CPP(HAVE_PYMOD_$1)=yes
- else
- AC_MSG_RESULT(no)
- eval AS_TR_CPP(HAVE_PYMOD_$1)=no
- #
- if test -n "$2"
- then
- AC_MSG_ERROR(failed to find required module $1)
- exit 1
- fi
- fi
-])
diff --git a/m4/cflags.m4 b/m4/cflags.m4
deleted file mode 100644
index 015d07b..0000000
--- a/m4/cflags.m4
+++ /dev/null
@@ -1,59 +0,0 @@
-# cflags.m4 - Test and set compiler flags
-#
-# Copyright 2011, 2012 Michael Steinert
-#
-# Permission is hereby granted, free of charge, to any person obtaining
-# a copy of this software and associated documentation files (the
-# "Software"), to deal in the Software without restriction, including
-# without limitation the rights to use, copy, modify, merge, publish,
-# distribute, sublicense, and/or sell copies of the Software, and to
-# permit persons to whom the Software is furnished to do so, subject to
-# the following conditions:
-#
-# The above copyright notice and this permission notice shall be
-# included in all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
-# SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
-# DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
-# OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR
-# THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
-#serial 1
-
-# AX_TRY_CFLAGS(FLAG, [ACTION-IF-TRUE], [ACTION-IF-FALSE])
-# --------------------------------------------------------
-# Test a compiler flag is supported.
-# FLAG: a compiler flag to try
-# ACTION-IF-TRUE: commands to execute if FLAG is supported
-# ACTION-IF-FALSE: commands to execute if FLAG is not supported
-AC_DEFUN([AX_TRY_CFLAGS],
-[dnl
-AC_REQUIRE([AC_PROG_CC])
-_ax_cflags=$CFLAGS
-CFLAGS="$1 $CFLAGS"
-AC_MSG_CHECKING([if compiler accepts '$1'])
-AC_TRY_COMPILE([], [],
- [AC_MSG_RESULT([yes])
- CFLAGS=$_ax_cflags
- $2],
- [AC_MSG_RESULT([no])
- CFLAGS=$_ax_cflags
- $3])
-])dnl
-
-# AX_CFLAGS(FLAGS)
-# ----------------
-# Enable compiler flags.
-# FLAGS: a whitespace-separated list of compiler flags to set
-AC_DEFUN([AX_CFLAGS],
-[dnl
-m4_foreach_w([_ax_flag], [$1],
- [AS_CASE([" $CFLAGS "],
- [*[[\ \ ]]_ax_flag[[\ \ ]]*],
- [],
- [*],
- [CFLAGS="$CFLAGS _ax_flag"])])
-])dnl
diff --git a/m4/ldflags.m4 b/m4/ldflags.m4
deleted file mode 100644
index bc07c7b..0000000
--- a/m4/ldflags.m4
+++ /dev/null
@@ -1,58 +0,0 @@
-# ldflags.m4 - Test and set linker flags
-#
-# Copyright 2011, 2012 Michael Steinert
-#
-# Permission is hereby granted, free of charge, to any person obtaining
-# a copy of this software and associated documentation files (the
-# "Software"), to deal in the Software without restriction, including
-# without limitation the rights to use, copy, modify, merge, publish,
-# distribute, sublicense, and/or sell copies of the Software, and to
-# permit persons to whom the Software is furnished to do so, subject to
-# the following conditions:
-#
-# The above copyright notice and this permission notice shall be
-# included in all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
-# SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
-# DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
-# OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR
-# THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
-#serial 1
-
-# AX_TRY_LDFLAGS(FLAG, [ACTION-IF-TRUE], [ACTION-IF-FALSE])
-# ---------------------------------------------------------
-# Test if a linker flag is supported.
-# FLAG: a linker flag to try
-# ACTION-IF-TRUE: commands to execute if FLAG is supported
-# ACTION-IF-FALSE: commands to execute if FLAG is not supported
-AC_DEFUN([AX_TRY_LDFLAGS],
-[dnl
-_ax_ldflags=$LDFLAGS
-LDFLAGS="$1 $LDFLAGS"
-AC_MSG_CHECKING([if linker accepts '$1'])
-AC_TRY_LINK([], [],
- [AC_MSG_RESULT([yes])
- LDFLAGS=$_ax_ldflags
- $2],
- [AC_MSG_RESULT([no])
- LDFLAGS=$_ax_ldflags
- $3])
-])dnl
-
-# AX_LDFLAGS(flags)
-# -----------------
-# Enable linker flags.
-# FLAGS: a whitespace-separated list of linker flags to set
-AC_DEFUN([AX_LDFLAGS],
-[dnl
-m4_foreach_w([_ax_flag], [$1],
- [AS_CASE([" $LDFLAGS "],
- [*[[\ \ ]]_ax_flag[[\ \ ]]*],
- [],
- [*],
- [LDFLAGS="$LDFLAGS _ax_flag"])])
-])dnl
diff --git a/m4/popt.m4 b/m4/popt.m4
deleted file mode 100644
index 55f4162..0000000
--- a/m4/popt.m4
+++ /dev/null
@@ -1,73 +0,0 @@
-# popt.m4 - Check for Popt
-#
-# Copyright 2012 Michael Steinert
-#
-# Permission is hereby granted, free of charge, to any person obtaining
-# a copy of this software and associated documentation files (the
-# "Software"), to deal in the Software without restriction, including
-# without limitation the rights to use, copy, modify, merge, publish,
-# distribute, sublicense, and/or sell copies of the Software, and to
-# permit persons to whom the Software is furnished to do so, subject to
-# the following conditions:
-#
-# The above copyright notice and this permission notice shall be
-# included in all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
-# SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
-# DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
-# OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR
-# THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
-#serial 1
-
-# _AX_LIB_POPT
-# ------------
-# Check for the Popt library and header file. If found the cache variable
-# ax_cv_have_popt will be set to yes.
-AC_DEFUN([_AX_LIB_POPT],
-[dnl
-ax_cv_have_popt=no
-_ax_popt_h=no
-_ax_popt_lib=no
-AC_ARG_VAR([POPT_CFLAGS], [C compiler flags for Popt, overriding defaults])
-AC_ARG_VAR([POPT_LIBS], [linker flags for Popt, overriding defaults])
-AC_CHECK_HEADERS([popt.h],
- [_ax_popt_h=yes],,
- [$POPT_CFLAGS])
-AS_IF([test "x$POPT_LIBS" = "x"],
- [AC_CHECK_LIB([popt], [poptGetContext],
- [POPT_LIBS=-lpopt
- _ax_popt_lib=yes])],
- [_ax_popt_cflags=$CFLAGS
- CFLAGS="$POPT_CFLAGS $CFLAGS"
- _ax_popt_ldflags=$LDFLAGS
- LDFLAGS="$POPT_LIBS $LDFLAGS"
- AC_MSG_CHECKING([for libpopt])
- AC_TRY_LINK([#include <popt.h>],
- [poptFreeContext(NULL)],
- [AC_MSG_RESULT([$POPT_LIBS])
- _ax_popt_lib=yes],
- [AC_MSG_RESULT([no])])
- CFLAGS=$_ax_popt_cflags
- LDFLAGS=$_ax_popt_ldflags])
-AS_IF([test "x$_ax_popt_h" = "xyes" && \
- test "x$_ax_popt_lib" = "xyes"],
- [ax_cv_have_popt=yes])
-])dnl
-
-# AX_LIB_POPT([ACTION-IF-TRUE], [ACTION-IF-FALSE])
-# ------------------------------------------------
-# Check is installed. If found the variable ax_have_popt will be set to yes.
-# ACTION-IF-TRUE: commands to execute if Popt is installed
-# ACTION-IF-FALSE: commands to execute if Popt is not installed
-AC_DEFUN([AX_LIB_POPT],
-[dnl
-AC_CACHE_VAL([ax_cv_have_popt], [_AX_LIB_POPT])
-ax_have_popt=$ax_cv_have_popt
-AS_IF([test "x$ax_have_popt" = "xyes"],
- [AC_DEFINE([HAVE_POPT], [1], [Define to 1 if Popt is available.])
- $1], [$2])
-])dnl
diff --git a/travis.sh b/travis.sh
index 7bf9383..8a63cca 100755
--- a/travis.sh
+++ b/travis.sh
@@ -1,12 +1,5 @@
#!/usr/bin/env bash
-build_autotools() {
- autoreconf -i
- ./configure --prefix=$PWD/_install
- make install
- make dist
-}
-
build_cmake() {
mkdir $PWD/_build && cd $PWD/_build
cmake .. -DCMAKE_INSTALL_PREFIX=$PWD/../_install -DCMAKE_C_FLAGS="-Werror" \
@@ -40,7 +33,7 @@ build_scan-build() {
}
if [ "$#" -ne 1 ]; then
- echo "Usage: $0 {autotools|cmake|asan|tsan|scan-build}"
+ echo "Usage: $0 {cmake|asan|tsan|scan-build}"
exit 1
fi