summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkokan <peter.kokai@balabit.com>2017-09-10 10:09:29 +0200
committerAlan Antonuk <alan.antonuk@gmail.com>2017-09-12 00:11:46 -0700
commit248f4d70693444de55910a3e2eaf9b2fb463beca (patch)
treea148cc5ef5b12319297e6b334d6d41c1488bf9a7
parent4b337fe0fa1f733b679014aa1e3b036ccbcd7635 (diff)
downloadrabbitmq-c-248f4d70693444de55910a3e2eaf9b2fb463beca.tar.gz
Compiling issue with autotools, clang -Werror.
Autotools configure steps fails, when clang is used with -Werror option. autoreconf (GNU Autoconf) 2.69 clang version 4.0.0-1ubuntu1 (tags/RELEASE_400/rc1) More details: The `AC_SEARCH_LIBS` creates a dummy function definition, with empty argument list, but in clang it is a warning unless void is given as parameter. Signed-off-by: kokan <peter.kokai@balabit.com>
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e618810..16f5eef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,6 +91,8 @@ AS_IF([test "x$os_win32" = xyes],
# Solaris needs -lsocket -lnsl
# QNX will need -lsocket
+saved_CFLAGS=$CFLAGS
+CFLAGS=
AC_SEARCH_LIBS([getaddrinfo], [socket], [],
[AC_CHECK_LIB([getaddrinfo], [socket],
[LIBS="-lsocket -lnsl $LIBS"],
@@ -188,6 +190,7 @@ AC_CONFIG_FILES([
librabbitmq.pc
Makefile
])
+CFLAGS=$saved_CFLAGS
AC_OUTPUT
AC_MSG_RESULT([
$PACKAGE_NAME build options: