summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Matthews <tmatth@videolan.org>2017-05-11 15:53:42 -0400
committerAlan Antonuk <alan.antonuk@gmail.com>2017-05-16 19:35:30 -0700
commit9e7f3703fdf23c4a88f6e5f959a6281f0f0550ec (patch)
tree4d8f2dd102b785b25d119e8ef8145b911be8a6c0
parent45ba6ed5fcfd84db532d8212f71854880ee36ca0 (diff)
downloadrabbitmq-c-9e7f3703fdf23c4a88f6e5f959a6281f0f0550ec.tar.gz
autotools: Fix linker errors when SSL is enabled
e.g., librabbitmq/.libs/librabbitmq.so: undefined reference to `pthread_once'
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index df4f8ef..014e5ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,6 +49,9 @@ librabbitmq_librabbitmq_la_SOURCES += \
librabbitmq/amqp_openssl_bio.h \
librabbitmq/amqp_openssl_hostname_validation.c \
librabbitmq/amqp_openssl_hostname_validation.h
+
+librabbitmq_librabbitmq_la_LDFLAGS += -pthread
+
if OS_APPLE
librabbitmq_librabbitmq_la_CFLAGS += -Wno-deprecated-declarations
endif