summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2015-10-13 22:23:52 -0700
committerAlan Antonuk <alan.antonuk@gmail.com>2015-10-13 22:43:54 -0700
commite65bb790f7334d347270b7e9a9b455bb1f5f3894 (patch)
tree89c969c7aafe133b3f0d839ba5a50e8496d32c5f
parent8f17d299778f01052a1fe9acf2cd759e75cd407c (diff)
downloadrabbitmq-c-e65bb790f7334d347270b7e9a9b455bb1f5f3894.tar.gz
autoconf: squash tabs in configure.ac
Be consistent through the whole file.
-rw-r--r--configure.ac60
1 files changed, 30 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index c439dbb..2c0eda8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,8 +17,8 @@ m4_define([soversion_revision], [4])
m4_define([soversion_age], [1])
AC_INIT([rabbitmq-c], [major_version.minor_version.micro_version],
- [https://github.com/alanxz/rabbitmq-c/issues], [rabbitmq-c],
- [http://www.rabbitmq.com/])
+ [https://github.com/alanxz/rabbitmq-c/issues], [rabbitmq-c],
+ [http://www.rabbitmq.com/])
AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([1.9 subdir-objects foreign -Wno-portability])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -31,9 +31,9 @@ LT_INIT([disable-static win32-dll])
# Program checks
m4_ifdef([AC_PROG_CC_89], [AC_PROG_CC_89],
- [AC_MSG_WARN([Attempt c89 workaround for old versions of autoconf])
- AC_PROG_CC
- AX_TRY_CFLAGS([-std=gnu90], [AX_CFLAGS([-std=gnu90])])])
+ [AC_MSG_WARN([Attempt c89 workaround for old versions of autoconf])
+ AC_PROG_CC
+ AX_TRY_CFLAGS([-std=gnu90], [AX_CFLAGS([-std=gnu90])])])
PKG_PROG_PKG_CONFIG([0.17])
# Environment setup
@@ -98,7 +98,7 @@ AC_SEARCH_LIBS([getaddrinfo], [socket], [],
[-lnsl])])
AC_SEARCH_LIBS([socket], [socket], [],
[AC_CHECK_LIB([socket], [socket],
- [LIBS="-lsocket -lnsl $LIBS"],
+ [LIBS="-lsocket -lnsl $LIBS"],
[AC_MSG_ERROR([cannot find socket library (library with socket symbol)])],
[-lnsl])])
AC_SEARCH_LIBS([clock_gettime], [rt])
@@ -149,34 +149,34 @@ AS_IF([test "x$with_ssl" != "xno"],
# Configure AMQP command-line tools
AC_ARG_ENABLE([tools],
- [AS_HELP_STRING([--enable-tools],
- [build AMQP command-line tools @<:@auto@:>@])],,
- [enable_tools=auto])
+ [AS_HELP_STRING([--enable-tools],
+ [build AMQP command-line tools @<:@auto@:>@])],,
+ [enable_tools=auto])
AS_IF([test "x$enable_tools" != "xno"],
[AX_LIB_POPT([enable_tools=yes], [enable_tools=no])])
AM_CONDITIONAL([TOOLS], [test "x$enable_tools" = "xyes"])
# Configure command-line tool documentation
AC_ARG_ENABLE([docs],
- [AS_HELP_STRING([--enable-docs],
- [build command-line tool documentation @<:@auto@:>@])],,
- [AS_IF([test "x$enable_tools" = "xno"],
- [enable_docs=no],
- [enable_docs=auto])])
+ [AS_HELP_STRING([--enable-docs],
+ [build command-line tool documentation @<:@auto@:>@])],,
+ [AS_IF([test "x$enable_tools" = "xno"],
+ [enable_docs=no],
+ [enable_docs=auto])])
AC_ARG_VAR([XMLTO], [xmlto command])
AS_IF([test "x$enable_docs" != "xno"],
- [AS_IF([test "x$XMLTO" = "x"],
- [AC_CHECK_PROGS([XMLTO], [xmlto])])
- AS_IF([test "x$XMLTO" != "x"],
- [enable_docs=yes],
- [enable_docs=no])])
+ [AS_IF([test "x$XMLTO" = "x"],
+ [AC_CHECK_PROGS([XMLTO], [xmlto])])
+ AS_IF([test "x$XMLTO" != "x"],
+ [enable_docs=yes],
+ [enable_docs=no])])
AM_CONDITIONAL([DOCS], [test "x$enable_docs" = "xyes"])
# Configure examples
AC_ARG_ENABLE([examples],
- [AS_HELP_STRING([--enable-examples],
- [build example code @<:@auto@:>@])],,
- [enable_examples=yes])
+ [AS_HELP_STRING([--enable-examples],
+ [build example code @<:@auto@:>@])],,
+ [enable_examples=yes])
AM_CONDITIONAL([EXAMPLES], [test "x$enable_examples" = "xyes"])
AC_SUBST([requires_private], [$ssl_pkg_required])
@@ -184,16 +184,16 @@ AC_SUBST([libs_private], [$LIBS])
AC_DEFINE_UNQUOTED([AMQ_PLATFORM], ["$host_os"], [Host operating system string])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([
- librabbitmq.pc
- Makefile
+ librabbitmq.pc
+ Makefile
])
AC_OUTPUT
AC_MSG_RESULT([
$PACKAGE_NAME build options:
- Host: $host
- Version: $VERSION
- SSL/TLS: $with_ssl
- Tools: $enable_tools
- Documentation: $enable_docs
- Examples: $enable_examples
+ Host: $host
+ Version: $VERSION
+ SSL/TLS: $with_ssl
+ Tools: $enable_tools
+ Documentation: $enable_docs
+ Examples: $enable_examples
])