summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBhasker Allam <abr5427@gmail.com>2015-04-04 14:51:12 -0700
committerAlan Antonuk <alan.antonuk@gmail.com>2015-04-05 23:37:23 -0700
commit9cf7a3b6c348fb01bc44eb6498836ed5bb7b7d66 (patch)
tree127c0376fe8775473ea38ee8df3feb5482b6b6eb
parentce0ce3a6cb3405d7bcbfbb497023a3f9e1630318 (diff)
downloadrabbitmq-c-9cf7a3b6c348fb01bc44eb6498836ed5bb7b7d66.tar.gz
Unit test for verify sasl mechanisms
-rw-r--r--Makefile.am6
-rw-r--r--librabbitmq/amqp_socket.c4
-rw-r--r--librabbitmq/amqp_socket.h3
-rw-r--r--tests/CMakeLists.txt4
-rw-r--r--tests/test_sasl_mechanism.c72
5 files changed, 86 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ffda6f..3f94714 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,7 +79,8 @@ check_PROGRAMS = \
tests/test_tables \
tests/test_parse_url \
tests/test_hostcheck \
- tests/test_status_enum
+ tests/test_status_enum \
+ tests/test_sasl_mechanism
TESTS = $(check_PROGRAMS)
@@ -96,6 +97,9 @@ tests_test_hostcheck_SOURCES = \
tests_test_status_enum_SOURCES = tests/test_status_enum.c
tests_test_status_enum_LDADD = librabbitmq/librabbitmq.a
+tests_test_sasl_mechanism_SOURCES = tests/test_sasl_mechanism.c
+tests_test_sasl_mechanism_LDADD = librabbitmq/librabbitmq.a
+
noinst_LTLIBRARIES =
if EXAMPLES
diff --git a/librabbitmq/amqp_socket.c b/librabbitmq/amqp_socket.c
index 03a8161..0036544 100644
--- a/librabbitmq/amqp_socket.c
+++ b/librabbitmq/amqp_socket.c
@@ -495,8 +495,8 @@ static int bytes_equal(amqp_bytes_t l, amqp_bytes_t r)
return 0;
}
-static int sasl_mechanism_in_list(amqp_bytes_t mechanisms,
- amqp_sasl_method_enum method)
+int sasl_mechanism_in_list(amqp_bytes_t mechanisms,
+ amqp_sasl_method_enum method)
{
amqp_bytes_t mechanism;
amqp_bytes_t supported_mechanism;
diff --git a/librabbitmq/amqp_socket.h b/librabbitmq/amqp_socket.h
index dad1a1e..4b25499 100644
--- a/librabbitmq/amqp_socket.h
+++ b/librabbitmq/amqp_socket.h
@@ -190,6 +190,9 @@ amqp_simple_wait_frame_on_channel(amqp_connection_state_t state,
amqp_channel_t channel,
amqp_frame_t *decoded_frame);
+int
+sasl_mechanism_in_list(amqp_bytes_t mechanisms, amqp_sasl_method_enum method);
+
AMQP_END_DECLS
#endif /* AMQP_SOCKET_H */
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index fca99fc..256aa18 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -28,3 +28,7 @@ add_executable(test_status_enum
test_status_enum.c)
target_link_libraries(test_status_enum rabbitmq-static)
add_test(status_enum test_status_enum)
+
+add_executable(test_sasl_mechanism test_sasl_mechanism.c)
+target_link_libraries(test_sasl_mechanism rabbitmq-static)
+add_test(sasl_mechanism test_sasl_mechanism)
diff --git a/tests/test_sasl_mechanism.c b/tests/test_sasl_mechanism.c
new file mode 100644
index 0000000..11a6d7c
--- /dev/null
+++ b/tests/test_sasl_mechanism.c
@@ -0,0 +1,72 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
+/*
+ * ***** BEGIN LICENSE BLOCK *****
+ * Version: MIT
+ *
+ * Portions created by Alan Antonuk are Copyright (c) 2012-2013
+ * Alan Antonuk. All Rights Reserved.
+ *
+ * Portions created by VMware are Copyright (c) 2007-2012 VMware, Inc.
+ * All Rights Reserved.
+ *
+ * Portions created by Tony Garnock-Jones are Copyright (c) 2009-2010
+ * VMware, Inc. and Tony Garnock-Jones. All Rights Reserved.
+ *
+ * Permission is hereby granted, free of charge, to any person
+ * obtaining a copy of this software and associated documentation
+ * files (the "Software"), to deal in the Software without
+ * restriction, including without limitation the rights to use, copy,
+ * modify, merge, publish, distribute, sublicense, and/or sell copies
+ * of the Software, and to permit persons to whom the Software is
+ * furnished to do so, subject to the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
+ * BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
+ * ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+ * CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ * SOFTWARE.
+ * ***** END LICENSE BLOCK *****
+ */
+
+#include <stdio.h>
+#include <string.h>
+#include <stdlib.h>
+
+#include <amqp_socket.h>
+
+static void parse_success(amqp_bytes_t mechanisms,
+ amqp_sasl_method_enum method)
+{
+ if (!sasl_mechanism_in_list(mechanisms, method)) {
+ fprintf(stderr,
+ "Expected to find mechanism in list, but didn't: %s\n",
+ (char *)mechanisms.bytes);
+ abort();
+ }
+}
+
+static void parse_fail(amqp_bytes_t mechanisms,
+ amqp_sasl_method_enum method)
+{
+ if (sasl_mechanism_in_list(mechanisms, method)) {
+ fprintf(stderr,
+ "Expected the mechanism not on the list, but it was present: %s\n",
+ (char *)mechanisms.bytes);
+ abort();
+ }
+}
+
+int main(void)
+{
+ parse_success(amqp_cstring_bytes("DIGEST-MD5 CRAM-MD5 LOGIN PLAIN"), AMQP_SASL_METHOD_PLAIN);
+ parse_fail(amqp_cstring_bytes("DIGEST-MD5 CRAM-MD5 LOGIN PLAIN"), AMQP_SASL_METHOD_EXTERNAL);
+ parse_success(amqp_cstring_bytes("DIGEST-MD5 CRAM-MD5 EXTERNAL"), AMQP_SASL_METHOD_EXTERNAL);
+ parse_fail(amqp_cstring_bytes("DIGEST-MD5 CRAM-MD5 EXTERNAL"), AMQP_SASL_METHOD_PLAIN);
+ return 0;
+}