summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2015-06-01 00:09:08 -0700
committerAlan Antonuk <alan.antonuk@gmail.com>2015-06-01 23:59:16 -0700
commit72affd5b9d13515bd8f6dbe40f953794ef260e81 (patch)
tree6709ad6747c6f035f32f6882df26eb626027bae4 /CMakeLists.txt
parent784a0e9078bc1c4145b0cb0a86045fe0f72fb691 (diff)
downloadrabbitmq-c-72affd5b9d13515bd8f6dbe40f953794ef260e81.tar.gz
win32: Enable static builds on Win32.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 095805f..7067b52 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -288,10 +288,6 @@ if (NOT BUILD_SHARED_LIBS AND NOT BUILD_STATIC_LIBS)
message(FATAL_ERROR "One or both of BUILD_SHARED_LIBS or BUILD_STATIC_LIBS must be set to ON to build")
endif()
-if (WIN32 AND BUILD_STATIC_LIBS)
- message(FATAL_ERROR "The rabbitmq-c library cannot be built as a static library on Win32. Set BUILD_STATIC_LIBS=OFF to get around this.")
-endif()
-
add_subdirectory(librabbitmq)
if (BUILD_EXAMPLES)