summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2015-06-07 00:21:17 -0700
committerAlan Antonuk <alan.antonuk@gmail.com>2015-06-07 00:21:17 -0700
commit8d77b4c84b68a0dab1a8c8f87cfe428df9a96ae4 (patch)
tree04dced17e8af4323df46bc333494eae470f46144 /CMakeLists.txt
parent94685b72dfa968b5f8cf9d0e1fec53e3f3fdfb79 (diff)
downloadrabbitmq-c-8d77b4c84b68a0dab1a8c8f87cfe428df9a96ae4.tar.gz
cmake: don't override CMAKE_C_FLAGS under clang.
The -Wall -Wextra... etc should be prepended to any passed in CMAKE_C_FLAGS as is done with gcc and others.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7067b52..2bca4cc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,7 @@ set(VERSION ${_API_VERSION_MAJOR}.${_API_VERSION_MINOR}.${_API_VERSION_PATCH})
if (MSVC)
set(CMAKE_C_FLAGS "/W4 /nologo ${CMAKE_C_FLAGS}")
elseif (CMAKE_C_COMPILER_ID MATCHES ".*Clang")
- set(CMAKE_C_FLAGS "-Wall -Wextra -pedantic -Wstrict-prototypes -Wcast-align -Wno-unused-function -fno-common -fvisibility=hidden")
+ set(CMAKE_C_FLAGS "-Wall -Wextra -pedantic -Wstrict-prototypes -Wcast-align -Wno-unused-function -fno-common -fvisibility=hidden ${CMAKE_C_FLAGS}")
elseif (CMAKE_COMPILER_IS_GNUCC)
set(RMQ_C_FLAGS "-Wall -Wextra -pedantic -Wstrict-prototypes -Wcast-align -Wno-unused-function -fno-common")
execute_process(COMMAND ${CMAKE_C_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)