summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2015-08-10 22:26:28 -0700
committerAlan Antonuk <alan.antonuk@gmail.com>2015-08-10 22:26:28 -0700
commit0ac6430d3a8d4c778cf5ff5e340d82a7f356652c (patch)
treeff599d74f442af3592433380d19760371868a7d0 /CMakeLists.txt
parentdb335c6f206eaf6080acba0108ed834a57dac047 (diff)
downloadrabbitmq-c-0ac6430d3a8d4c778cf5ff5e340d82a7f356652c.tar.gz
ci: reenable mistakenly removed CFLAGS
-Wstrict-prototypes -Wno-unused-function have some use, leave them in.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a683fb5..69d7906 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,9 +37,9 @@ set(VERSION ${_API_VERSION_MAJOR}.${_API_VERSION_MINOR}.${_API_VERSION_PATCH})
if (MSVC)
set(CMAKE_C_FLAGS "/W4 /nologo ${CMAKE_C_FLAGS}")
elseif (CMAKE_C_COMPILER_ID MATCHES ".*Clang")
- set(CMAKE_C_FLAGS "-Wall -Wextra -fno-common -fvisibility=hidden ${CMAKE_C_FLAGS}")
+ set(CMAKE_C_FLAGS "-Wall -Wextra -Wstrict-prototypes -Wno-unused-function -fno-common -fvisibility=hidden ${CMAKE_C_FLAGS}")
elseif (CMAKE_COMPILER_IS_GNUCC)
- set(RMQ_C_FLAGS "-Wall -Wextra -fno-common")
+ set(RMQ_C_FLAGS "-Wall -Wextra -Wstrict-prototypes -Wno-unused-function -fno-common")
execute_process(COMMAND ${CMAKE_C_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
if (GCC_VERSION VERSION_GREATER 4.0 OR GCC_VERSION VERSION_EQUAL 4.0)
set(RMQ_C_FLAGS "${RMQ_C_FLAGS} -fvisibility=hidden")