summaryrefslogtreecommitdiff
path: root/examples/tutorial-1-hello-world/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2017-02-20 18:23:05 -0800
committerAlan Antonuk <alan.antonuk@gmail.com>2017-02-20 18:23:05 -0800
commit2424fe354d7e38fdc7bfe2fba3c5826a935aa329 (patch)
tree0f6d1cea22d3553082e8ad9de497c6c587485e77 /examples/tutorial-1-hello-world/CMakeLists.txt
parent31f840b79a085418aff4366509056d9112adf402 (diff)
downloadrabbitmq-c-2424fe354d7e38fdc7bfe2fba3c5826a935aa329.tar.gz
Examples: add tutorial 1 example code.tutorial
Add a hello-world sender (send.c) and receiver (recv.c) examples that matches what is done in tutorial #1 on the RabbitMQ website.
Diffstat (limited to 'examples/tutorial-1-hello-world/CMakeLists.txt')
-rw-r--r--examples/tutorial-1-hello-world/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/examples/tutorial-1-hello-world/CMakeLists.txt b/examples/tutorial-1-hello-world/CMakeLists.txt
new file mode 100644
index 0000000..d4dc54c
--- /dev/null
+++ b/examples/tutorial-1-hello-world/CMakeLists.txt
@@ -0,0 +1,6 @@
+
+add_executable(send send.c)
+target_link_libraries(send ${RMQ_LIBRARY_TARGET})
+
+add_executable(recv recv.c)
+target_link_libraries(recv ${RMQ_LIBRARY_TARGET})