summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorTony Garnock-Jones <tonyg@kcbbs.gen.nz>2009-04-27 00:44:59 +0100
committerTony Garnock-Jones <tonyg@kcbbs.gen.nz>2009-04-27 00:44:59 +0100
commit3a51512706eb5dcebb6c8e2d4dcd571273f49899 (patch)
tree7cd5af04f901aba44f1ce43bccb6685b97ef33f6 /examples
parente954a0bf0d30c21b5563db2fd07e5d85d076edc2 (diff)
downloadrabbitmq-c-3a51512706eb5dcebb6c8e2d4dcd571273f49899.tar.gz
More examples; clean shutdown
Diffstat (limited to 'examples')
-rw-r--r--examples/Makefile.am8
-rw-r--r--examples/amqp_exchange_declare.c62
-rw-r--r--examples/amqp_listen.c152
-rw-r--r--examples/amqp_sendstring.c64
-rw-r--r--examples/example_utils.c57
-rw-r--r--examples/example_utils.h7
6 files changed, 288 insertions, 62 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 226294f..45f0308 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,4 +1,10 @@
-bin_PROGRAMS = amqp_sendstring
+bin_PROGRAMS = amqp_sendstring amqp_exchange_declare amqp_listen
AM_CFLAGS = -I../librabbitmq
AM_LDFLAGS = ../librabbitmq/librabbitmq.la
+
+nodist_INCLUDES = example_utils.h
+
+amqp_sendstring_SOURCES = amqp_sendstring.c example_utils.c
+amqp_exchange_declare_SOURCES = amqp_exchange_declare.c example_utils.c
+amqp_listen_SOURCES = amqp_listen.c example_utils.c
diff --git a/examples/amqp_exchange_declare.c b/examples/amqp_exchange_declare.c
new file mode 100644
index 0000000..d03290e
--- /dev/null
+++ b/examples/amqp_exchange_declare.c
@@ -0,0 +1,62 @@
+#include <stdlib.h>
+#include <stdio.h>
+#include <string.h>
+
+#include <stdint.h>
+#include <amqp.h>
+#include <amqp_framing.h>
+
+#include <unistd.h>
+
+#include "example_utils.h"
+
+int main(int argc, char const * const *argv) {
+ char const *hostname;
+ int port;
+ char const *exchange;
+ char const *exchangetype;
+
+ int sockfd;
+ amqp_connection_state_t conn;
+
+ if (argc < 5) {
+ fprintf(stderr, "Usage: amqp_exchange_declare host port exchange exchangetype\n");
+ return 1;
+ }
+
+ hostname = argv[1];
+ port = atoi(argv[2]);
+ exchange = argv[3];
+ exchangetype = argv[4];
+
+ conn = amqp_new_connection();
+
+ die_on_error(sockfd = amqp_open_socket(hostname, port), "Opening socket");
+ amqp_set_sockfd(conn, sockfd);
+ die_on_amqp_error(amqp_login(conn, "/", 131072, AMQP_SASL_METHOD_PLAIN, "guest", "guest"),
+ "Logging in");
+
+ {
+ amqp_exchange_declare_t s =
+ (amqp_exchange_declare_t) {
+ .ticket = 0,
+ .exchange = amqp_cstring_bytes(exchange),
+ .type = amqp_cstring_bytes(exchangetype),
+ .passive = 0,
+ .durable = 0,
+ .auto_delete = 0,
+ .internal = 0,
+ .nowait = 0,
+ .arguments = {.num_entries = 0, .entries = NULL}
+ };
+ die_on_amqp_error(amqp_simple_rpc(conn, 1, AMQP_EXCHANGE_DECLARE_METHOD,
+ AMQP_EXCHANGE_DECLARE_OK_METHOD, &s),
+ "Declaring exchange");
+ }
+
+ die_on_amqp_error(amqp_channel_close(conn, AMQP_REPLY_SUCCESS), "Closing channel");
+ die_on_amqp_error(amqp_connection_close(conn, AMQP_REPLY_SUCCESS), "Closing connection");
+ amqp_destroy_connection(conn);
+ die_on_error(close(sockfd), "Closing socket");
+ return 0;
+}
diff --git a/examples/amqp_listen.c b/examples/amqp_listen.c
new file mode 100644
index 0000000..b67474d
--- /dev/null
+++ b/examples/amqp_listen.c
@@ -0,0 +1,152 @@
+#include <stdlib.h>
+#include <stdio.h>
+#include <string.h>
+
+#include <stdint.h>
+#include <amqp.h>
+#include <amqp_framing.h>
+
+#include <unistd.h>
+
+#include "example_utils.h"
+
+/* Private: compiled out in NDEBUG mode */
+extern void amqp_dump(void const *buffer, size_t len);
+
+int main(int argc, char const * const *argv) {
+ char const *hostname;
+ int port;
+ char const *exchange;
+ char const *bindingkey;
+
+ int sockfd;
+ amqp_connection_state_t conn;
+
+ amqp_rpc_reply_t result;
+ amqp_bytes_t queuename;
+
+ if (argc < 5) {
+ fprintf(stderr, "Usage: amqp_listen host port exchange bindingkey\n");
+ return 1;
+ }
+
+ hostname = argv[1];
+ port = atoi(argv[2]);
+ exchange = argv[3];
+ bindingkey = argv[4];
+
+ conn = amqp_new_connection();
+
+ die_on_error(sockfd = amqp_open_socket(hostname, port), "Opening socket");
+ amqp_set_sockfd(conn, sockfd);
+ die_on_amqp_error(amqp_login(conn, "/", 131072, AMQP_SASL_METHOD_PLAIN, "guest", "guest"),
+ "Logging in");
+
+ {
+ amqp_queue_declare_t s =
+ (amqp_queue_declare_t) {
+ .ticket = 0,
+ .queue = {.len = 0, .bytes = NULL},
+ .passive = 0,
+ .durable = 0,
+ .exclusive = 0,
+ .auto_delete = 1,
+ .nowait = 0,
+ .arguments = {.num_entries = 0, .entries = NULL}
+ };
+ die_on_amqp_error(result = amqp_simple_rpc(conn, 1, AMQP_QUEUE_DECLARE_METHOD,
+ AMQP_QUEUE_DECLARE_OK_METHOD, &s),
+ "Declaring queue");
+ amqp_queue_declare_ok_t *r = (amqp_queue_declare_ok_t *) result.reply.decoded;
+ queuename = amqp_bytes_malloc_dup(r->queue);
+ }
+
+ {
+ amqp_queue_bind_t s =
+ (amqp_queue_bind_t) {
+ .ticket = 0,
+ .queue = queuename,
+ .exchange = amqp_cstring_bytes(exchange),
+ .routing_key = amqp_cstring_bytes(bindingkey),
+ .nowait = 0,
+ .arguments = {.num_entries = 0, .entries = NULL}
+ };
+ die_on_amqp_error(result = amqp_simple_rpc(conn, 1, AMQP_QUEUE_BIND_METHOD,
+ AMQP_QUEUE_BIND_OK_METHOD, &s),
+ "Binding queue");
+ }
+
+ {
+ amqp_basic_consume_t s =
+ (amqp_basic_consume_t) {
+ .ticket = 0,
+ .queue = queuename,
+ .consumer_tag = {.len = 0, .bytes = NULL},
+ .no_local = 0,
+ .no_ack = 1,
+ .exclusive = 0,
+ .nowait = 0
+ };
+ die_on_amqp_error(result = amqp_simple_rpc(conn, 1, AMQP_BASIC_CONSUME_METHOD,
+ AMQP_BASIC_CONSUME_OK_METHOD, &s),
+ "Consuming");
+ }
+
+ {
+ amqp_frame_t frame;
+ int result;
+
+ while (1) {
+ amqp_maybe_release_buffers(conn);
+ result = amqp_simple_wait_frame(conn, &frame);
+ printf("Result %d\n", result);
+ if (result <= 0) goto shutdown;
+
+ analyse_frame:
+ printf("Frame type %d, channel %d\n", frame.frame_type, frame.channel);
+ if (frame.frame_type == AMQP_FRAME_METHOD) {
+ printf("Method %s\n", amqp_method_name(frame.payload.method.id));
+ if (frame.payload.method.id == AMQP_BASIC_DELIVER_METHOD) {
+ amqp_basic_deliver_t *d = (amqp_basic_deliver_t *) frame.payload.method.decoded;
+ amqp_basic_properties_t *p;
+ printf("Delivery %llu, exchange %.*s routingkey %.*s\n",
+ d->delivery_tag,
+ (int) d->exchange.len, (char *) d->exchange.bytes,
+ (int) d->routing_key.len, (char *) d->routing_key.bytes);
+
+ result = amqp_simple_wait_frame(conn, &frame);
+ if (result <= 0) goto shutdown;
+ if (frame.frame_type != AMQP_FRAME_HEADER) {
+ fprintf(stderr, "Expected header!");
+ abort();
+ }
+ p = (amqp_basic_properties_t *) frame.payload.properties.decoded;
+ if (p->_flags & AMQP_BASIC_CONTENT_TYPE_FLAG) {
+ printf("Content-type: %.*s\n",
+ (int) p->content_type.len, (char *) p->content_type.bytes);
+ }
+ printf("----\n");
+
+ while (1) {
+ result = amqp_simple_wait_frame(conn, &frame);
+ if (result <= 0) goto shutdown;
+ if (frame.frame_type != AMQP_FRAME_BODY) {
+ printf("====\n");
+ goto analyse_frame;
+ }
+ amqp_dump(frame.payload.body_fragment.bytes,
+ frame.payload.body_fragment.len);
+ }
+ }
+ }
+ }
+ }
+
+ shutdown:
+ die_on_amqp_error(amqp_channel_close(conn, AMQP_REPLY_SUCCESS), "Closing channel");
+ die_on_amqp_error(amqp_connection_close(conn, AMQP_REPLY_SUCCESS), "Closing connection");
+ amqp_destroy_connection(conn);
+ die_on_error(close(sockfd), "Closing socket");
+
+ return 0;
+}
diff --git a/examples/amqp_sendstring.c b/examples/amqp_sendstring.c
index 77d8fd3..c914f86 100644
--- a/examples/amqp_sendstring.c
+++ b/examples/amqp_sendstring.c
@@ -8,55 +8,7 @@
#include <unistd.h>
-static void die_on_error(int x, char const *context) {
- if (x < 0) {
- fprintf(stderr, "%s: %s\n", context, strerror(-x));
- exit(1);
- }
-}
-
-static void die_on_amqp_error(amqp_rpc_reply_t x, char const *context) {
- switch (x.reply_type) {
- case AMQP_RESPONSE_NORMAL:
- return;
-
- case AMQP_RESPONSE_NONE:
- fprintf(stderr, "%s: missing RPC reply type!", context);
- break;
-
- case AMQP_RESPONSE_LIBRARY_EXCEPTION:
- fprintf(stderr, "%s: %s\n", context, strerror(x.library_errno));
- break;
-
- case AMQP_RESPONSE_SERVER_EXCEPTION:
- switch (x.reply.id) {
- case AMQP_CONNECTION_CLOSE_METHOD: {
- amqp_connection_close_t *m = (amqp_connection_close_t *) x.reply.decoded;
- fprintf(stderr, "%s: server connection error %d, message: %*s",
- context,
- m->reply_code,
- (int) m->reply_text.len,
- (char *) m->reply_text.bytes);
- break;
- }
- case AMQP_CHANNEL_CLOSE_METHOD: {
- amqp_channel_close_t *m = (amqp_channel_close_t *) x.reply.decoded;
- fprintf(stderr, "%s: server channel error %d, message: %*s",
- context,
- m->reply_code,
- (int) m->reply_text.len,
- (char *) m->reply_text.bytes);
- break;
- }
- default:
- fprintf(stderr, "%s: unknown server error, method id 0x%08X", context, x.reply.id);
- break;
- }
- break;
- }
-
- exit(1);
-}
+#include "example_utils.h"
int main(int argc, char const * const *argv) {
char const *hostname;
@@ -100,19 +52,9 @@ int main(int argc, char const * const *argv) {
"Publishing");
}
- printf("Waiting for frames...\n");
- while (1) {
- amqp_frame_t frame;
- int result = amqp_simple_wait_frame(conn, &frame);
- printf("Result %d\n", result);
- printf("Frame type %d, channel %d\n", frame.frame_type, frame.channel);
- if (result == 0) break;
- amqp_maybe_release_buffers(conn);
- }
-
+ die_on_amqp_error(amqp_channel_close(conn, AMQP_REPLY_SUCCESS), "Closing channel");
+ die_on_amqp_error(amqp_connection_close(conn, AMQP_REPLY_SUCCESS), "Closing connection");
amqp_destroy_connection(conn);
-
die_on_error(close(sockfd), "Closing socket");
-
return 0;
}
diff --git a/examples/example_utils.c b/examples/example_utils.c
new file mode 100644
index 0000000..7c01074
--- /dev/null
+++ b/examples/example_utils.c
@@ -0,0 +1,57 @@
+#include <stdlib.h>
+#include <stdio.h>
+#include <string.h>
+
+#include <stdint.h>
+#include <amqp.h>
+#include <amqp_framing.h>
+
+#include <unistd.h>
+
+void die_on_error(int x, char const *context) {
+ if (x < 0) {
+ fprintf(stderr, "%s: %s\n", context, strerror(-x));
+ exit(1);
+ }
+}
+
+void die_on_amqp_error(amqp_rpc_reply_t x, char const *context) {
+ switch (x.reply_type) {
+ case AMQP_RESPONSE_NORMAL:
+ return;
+
+ case AMQP_RESPONSE_NONE:
+ fprintf(stderr, "%s: missing RPC reply type!", context);
+ break;
+
+ case AMQP_RESPONSE_LIBRARY_EXCEPTION:
+ fprintf(stderr, "%s: %s\n", context, strerror(x.library_errno));
+ break;
+
+ case AMQP_RESPONSE_SERVER_EXCEPTION:
+ switch (x.reply.id) {
+ case AMQP_CONNECTION_CLOSE_METHOD: {
+ amqp_connection_close_t *m = (amqp_connection_close_t *) x.reply.decoded;
+ fprintf(stderr, "%s: server connection error %d, message: %.*s",
+ context,
+ m->reply_code,
+ (int) m->reply_text.len, (char *) m->reply_text.bytes);
+ break;
+ }
+ case AMQP_CHANNEL_CLOSE_METHOD: {
+ amqp_channel_close_t *m = (amqp_channel_close_t *) x.reply.decoded;
+ fprintf(stderr, "%s: server channel error %d, message: %.*s",
+ context,
+ m->reply_code,
+ (int) m->reply_text.len, (char *) m->reply_text.bytes);
+ break;
+ }
+ default:
+ fprintf(stderr, "%s: unknown server error, method id 0x%08X", context, x.reply.id);
+ break;
+ }
+ break;
+ }
+
+ exit(1);
+}
diff --git a/examples/example_utils.h b/examples/example_utils.h
new file mode 100644
index 0000000..eda03e7
--- /dev/null
+++ b/examples/example_utils.h
@@ -0,0 +1,7 @@
+#ifndef librabbitmq_examples_example_utils_h
+#define librabbitmq_examples_example_utils_h
+
+extern void die_on_error(int x, char const *context);
+extern void die_on_amqp_error(amqp_rpc_reply_t x, char const *context);
+
+#endif