summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt4
-rw-r--r--tests/CMakeLists.txt1
2 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 095805f..7067b52 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -288,10 +288,6 @@ if (NOT BUILD_SHARED_LIBS AND NOT BUILD_STATIC_LIBS)
message(FATAL_ERROR "One or both of BUILD_SHARED_LIBS or BUILD_STATIC_LIBS must be set to ON to build")
endif()
-if (WIN32 AND BUILD_STATIC_LIBS)
- message(FATAL_ERROR "The rabbitmq-c library cannot be built as a static library on Win32. Set BUILD_STATIC_LIBS=OFF to get around this.")
-endif()
-
add_subdirectory(librabbitmq)
if (BUILD_EXAMPLES)
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index d5df59a..a9a41a6 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -9,6 +9,7 @@ if (MSVC)
endif (MSVC)
add_definitions(-DHAVE_CONFIG_H)
+add_definitions(-DAMQP_STATIC)
add_executable(test_parse_url test_parse_url.c)
target_link_libraries(test_parse_url rabbitmq-static)