summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshley Camba <ashwoods@gmail.com>2017-07-17 15:40:44 +0200
committerGitHub <noreply@github.com>2017-07-17 15:40:44 +0200
commit1e52542261a5c5846f3209e72a72b73bf44c9d1b (patch)
treeeac2457ffb9ae07c451d36a8278e599dfb30a61a
parent28cf1846633193fdf3ca8cf7a790c86b68a9355a (diff)
parent9d32608e7283831df9eae0905051369ad93c716c (diff)
downloadraven-1e52542261a5c5846f3209e72a72b73bf44c9d1b.tar.gz
Merge pull request #1038 from ashwoods/docs/readme
Update Docs/readme
-rw-r--r--README.rst124
-rw-r--r--docs/platform-support.rst2
-rwxr-xr-xsetup.py3
3 files changed, 119 insertions, 10 deletions
diff --git a/README.rst b/README.rst
index 8d5d2bf..481a239 100644
--- a/README.rst
+++ b/README.rst
@@ -1,24 +1,128 @@
-Raven
-======
+.. raw:: html
+
+ <p align="center">
+
+.. image:: docs/_static/logo.png
+ :target: https://sentry.io
+ :align: center
+ :width: 116
+ :alt: Sentry website
+
+.. raw:: html
+
+ </p>
+
+Raven - Sentry for Python
+=========================
+
+.. image:: https://img.shields.io/pypi/v/raven.svg
+ :target: https://pypi.python.org/pypi/raven
+ :alt: PyPi page link -- version
.. image:: https://travis-ci.org/getsentry/raven-python.svg?branch=master
:target: https://travis-ci.org/getsentry/raven-python
-Raven is a Python client for `Sentry <http://getsentry.com/>`_. It provides
-full out-of-the-box support for many of the popular frameworks, including
+.. image:: https://img.shields.io/pypi/l/raven.svg
+ :target: https://pypi.python.org/pypi/raven
+ :alt: PyPi page link -- MIT licence
+
+.. image:: https://img.shields.io/pypi/pyversions/raven.svg
+ :target: https://pypi.python.org/pypi/raven
+ :alt: PyPi page link -- Python versions
+
+.. image:: https://codeclimate.com/github/getsentry/raven-python/badges/gpa.svg
+ :target: https://codeclimate.com/github/codeclimate/codeclimate
+ :alt: Code Climate
+
+
+Raven is the official Python client for `Sentry`_, officially supports
+Python 2.6–2.7 & 3.3–3.7, and runs on PyPy and Google App Engine.
+
+It tracks errors and exceptions that happen during the
+execution of your application and provides instant notification with detailed
+information needed to prioritize, identify, reproduce and fix each issue.
+
+It provides full out-of-the-box support for many of the popular python frameworks, including
Django, and Flask. Raven also includes drop-in support for any WSGI-compatible
web application.
Your application doesn't live on the web? No problem! Raven is easy to use in
any Python application.
+For more information, see our `Python Documentation`_ for framework integrations and other goodies.
+
+
+Features
+--------
+
+- Automatically report (un)handled exceptions and errors
+- Send customized diagnostic data
+- Process and sanitize data before sending it over the network
+
+
+Quickstart
+----------
+
+It's really easy to get started with Raven. After you complete setting up a project in Sentry,
+you’ll be given a value which we call a DSN, or Data Source Name. You will need it to configure the client.
+
+
+Install the latest package with *pip* and configure the client::
+
+ pip install raven --upgrade
+
+Create a client and capture an example exception:
+
+.. sourcecode:: python
+
+ from raven import Client
+
+ client = Client('___DSN___')
+
+ try:
+ 1 / 0
+ except ZeroDivisionError:
+ client.captureException()
+
+
+Raven Python is more than that however. Checkout our `Python Documentation`_.
+
+
+Contributing
+------------
+
+Raven is under active development and contributions are more than welcome!
+There are many ways to contribute:
+
+* Join in on discussions on our `Mailing List`_ or in our `IRC Channel`_.
+
+* Report bugs on our `Issue Tracker`_.
+
+* Submit a pull request!
+
+
Resources
---------
-* `Documentation <https://docs.getsentry.com/hosted/clients/python/>`_
-* `Bug Tracker <http://github.com/getsentry/raven-python/issues>`_
-* `Code <http://github.com/getsentry/raven-python>`_
-* `Mailing List <https://groups.google.com/group/getsentry>`_
-* `IRC <irc://irc.freenode.net/sentry>`_ (irc.freenode.net, #sentry)
-* `Travis CI <http://travis-ci.org/getsentry/raven-python>`_
+* `Sentry`_
+* `Python Documentation`_
+* `Issue Tracker`_
+* `Code`_ on Github
+* `Mailing List`_
+* `IRC Channel`_ (irc.freenode.net, #sentry)
+* `Travis CI`_
+
+.. _Sentry: https://getsentry.com/
+.. _Python Documentation: https://docs.getsentry.com/hosted/clients/python/
+.. _SDKs for other platforms: https://docs.sentry.io/#platforms
+.. _Issue Tracker: https://github.com/getsentry/raven-python/issues
+.. _Code: https://github.com/getsentry/raven-python
+.. _Mailing List: https://groups.google.com/group/getsentry
+.. _IRC Channel: irc://irc.freenode.net/sentry
+.. _Travis CI: http://travis-ci.org/getsentry/raven-python
+
+
+
+
+Not using Python? Check out our `SDKs for other platforms`_.
diff --git a/docs/platform-support.rst b/docs/platform-support.rst
index 9e37274..dd0fa96 100644
--- a/docs/platform-support.rst
+++ b/docs/platform-support.rst
@@ -5,5 +5,7 @@ Supported Platforms
- Python 2.7
- Python 3.2
- Python 3.3
+- Python 3.5
+- Python 3.6
- PyPy
- Google App Engine
diff --git a/setup.py b/setup.py
index 8e6d5ae..7e91788 100755
--- a/setup.py
+++ b/setup.py
@@ -137,11 +137,14 @@ setup(
'Intended Audience :: System Administrators',
'Operating System :: OS Independent',
'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python',
'Topic :: Software Development',
],