summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Michael Auer <account@jauer.org>2017-10-19 19:53:05 +0200
committerAshley Camba <ashwoods@gmail.com>2017-10-19 19:53:05 +0200
commitcd5583857ca69807540b4da05f0a293774f2e296 (patch)
tree2321e4bb5afa113f6212baaf339bb1222834a7ef
parente1fd30be2af23f049f6ccdcdb81061e7359f99dc (diff)
downloadraven-cd5583857ca69807540b4da05f0a293774f2e296.tar.gz
ci: Use probot to release (#1111)
* ci(travis): Deploy tags to S3 * ci(release): Activate the release bot * meta(changelog): Move the changelog to the standard location * ci(travis): Set python version explicitly on deploy
-rw-r--r--.github/release.yml3
-rw-r--r--.travis.yml27
-rw-r--r--CHANGELOG.md (renamed from CHANGES)0
3 files changed, 19 insertions, 11 deletions
diff --git a/.github/release.yml b/.github/release.yml
new file mode 100644
index 0000000..9fe7023
--- /dev/null
+++ b/.github/release.yml
@@ -0,0 +1,3 @@
+targets:
+ - github
+ - pypi
diff --git a/.travis.yml b/.travis.yml
index f5c28e3..0ff228f 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -123,17 +123,22 @@ jobs:
python: 3.6
env: TOXENV=py36-lambda
-# - stage: deploy
-# script: skip
-# deploy:
-# provider: pypi
-# user: sentry
-# distributions: "sdist--formats=gztar bdist_wheel"
-# on:
-# tags: true
-# repo: getsentry/raven-python
-# password:
-# secure: cG4yO9C+42ljfMlCfIJEgmySUPDCmGht358UaaCum4qchpVaFrjPAvm2sUpr3cFhUmMH+ueUr7LBW2c+lriJyT7wwJlU7vwtECzr5aayUuSwwPpFu98lz8kwQny3KF2caMD15rbjXkDRjh1QXw4ztiuBZq9dLb5WDx3pIKVLLbQ=
+ - stage: deploy
+ script: ./setup.py sdist --formats=gztar bdist_wheel
+ if: tag IS present
+ python: 2.7
+ deploy:
+ provider: s3
+ access_key_id: AKIAJKYWAF3QS7SFL75Q
+ secret_access_key:
+ secure: HFlh3wzzYIbkIYRt+Qu60ak0U1+RFagr3nI+EqX/9KJH0zwLg/Xv1Gfx4vZZ+0VZkeJIbZZC5l4HxUzFwkROepxPh0Foifqm7hRKL4HUBdvIONcW+h3Ilanvyj/0tIyRdFPK5pZ22qc+1nsARy0eYEtz/YQeEhiEohvNxbhOuUQ=
+ skip_cleanup: true
+ acl: public_read
+ bucket: getsentry-builds
+ upload-dir: $TRAVIS_REPO_SLUG/$TRAVIS_COMMIT
+ local_dir: build
+ on:
+ tags: true
script: tox
install:
diff --git a/CHANGES b/CHANGELOG.md
index 07004d8..07004d8 100644
--- a/CHANGES
+++ b/CHANGELOG.md