summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshley Camba Garrido <ashwoods@gmail.com>2017-12-31 14:51:01 +0100
committerAshley Camba <ashwoods@gmail.com>2018-01-01 10:56:46 +0100
commit05539fc0de94ff8ec6e199552b6c6b65cb4b396e (patch)
tree5c748db6fbf56303a995100e9c94218cbabf717d
parent20655d1f96700000f38da90e49b55c619294a49f (diff)
downloadraven-05539fc0de94ff8ec6e199552b6c6b65cb4b396e.tar.gz
Add xdist coverage, bumb versions and add params to cfg
-rw-r--r--.gitignore2
-rw-r--r--setup.cfg2
-rwxr-xr-xsetup.py4
-rw-r--r--tox.ini2
4 files changed, 5 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index 8270081..333249c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,7 +4,7 @@
*.db
*.pid
.python-version
-.coverage
+.coverage*
.DS_Store
.tox
pip-log.txt
diff --git a/setup.cfg b/setup.cfg
index f818766..8c465d8 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[tool:pytest]
python_files=test*.py
-addopts=--tb=native -p no:doctest
+addopts=--tb=native -p no:doctest -p no:logging --cov=raven -nauto
norecursedirs=raven build bin dist docs htmlcov hooks node_modules .* {args}
DJANGO_SETTINGS_MODULE = tests.contrib.django.settings
python_paths = tests
diff --git a/setup.py b/setup.py
index 97f4979..3911020 100755
--- a/setup.py
+++ b/setup.py
@@ -70,9 +70,9 @@ tests_require = [
'pytest-timeout==1.2.0',
'pytest-xdist==1.18.2',
'pytest-pythonpath==0.7.1',
- 'pytest-sugar==0.8',
+ 'pytest-sugar==0.9.0',
'pytest-cov',
- 'pytest-flake8==0.9',
+ 'pytest-flake8==0.9.1',
'requests',
'tornado>=4.1',
'webob',
diff --git a/tox.ini b/tox.ini
index cd0a5a1..ea91644 100644
--- a/tox.ini
+++ b/tox.ini
@@ -67,7 +67,7 @@ basepython =
pypy: pypy
commands =
- py.test {env:TESTPATH} --cov=raven {posargs}
+ py.test {env:TESTPATH} {posargs}
# Linters
[testenv:flake8]