summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Robenolt <m@robenolt.com>2013-11-13 08:02:13 -0800
committerMatt Robenolt <m@robenolt.com>2013-11-13 08:02:13 -0800
commit4efb80ef40bdbae3940694909c470bf43732cbc3 (patch)
treeae750bca8cea1ad8af806935f3b33eefc74bb50c
parent56bb158fb03b917b27bd52f4c7812c9802826ce9 (diff)
parent99d3e20ea881207b05d43d489770c6ef05dc09a5 (diff)
downloadraven-4efb80ef40bdbae3940694909c470bf43732cbc3.tar.gz
Merge pull request #381 from mattrobenolt/wheel
Package up as a wheel
-rw-r--r--Makefile5
-rw-r--r--setup.cfg3
2 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 20f7e32..aa9b35c 100644
--- a/Makefile
+++ b/Makefile
@@ -21,3 +21,8 @@ coverage:
setup-git:
git config branch.autosetuprebase always
cd .git/hooks && ln -sf ../../hooks/* ./
+
+publish:
+ python setup.py sdist bdist_wheel upload
+
+.PHONY: bootstrap test lint coverage setup-git publish
diff --git a/setup.cfg b/setup.cfg
index bf07533..ee0f521 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -6,3 +6,6 @@ addopts=--tb=short
ignore = F999,E501,E128,E124
max-line-length = 100
exclude = .tox,.git,docs
+
+[wheel]
+universal = 1