summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Yan <felixonmars@archlinux.org>2016-07-08 15:28:49 +0800
committerFelix Yan <felixonmars@archlinux.org>2016-07-08 15:28:49 +0800
commitfe6068a34cc1326548e73f294ba00c3255155a9b (patch)
treee4e3a2b3a170fcd921a95635dfbb12887fe6ebc0
parent81c9b81667061bb512f9d9f2dafb86857237122f (diff)
downloadraven-fe6068a34cc1326548e73f294ba00c3255155a9b.tar.gz
Update to latest flake8 and use pycodestyle
-rwxr-xr-xhooks/pre-commit.flake82
-rwxr-xr-xsetup.py4
2 files changed, 3 insertions, 3 deletions
diff --git a/hooks/pre-commit.flake8 b/hooks/pre-commit.flake8
index 1850e90..d7b9071 100755
--- a/hooks/pre-commit.flake8
+++ b/hooks/pre-commit.flake8
@@ -6,7 +6,7 @@ import sys
os.environ['PYFLAKES_NODOCTEST'] = '1'
-# pep8.py uses sys.argv to find setup.cfg
+# pycodestyle.py uses sys.argv to find setup.cfg
sys.argv = [os.path.join(os.path.dirname(__file__), os.pardir, os.pardir)]
# git usurbs your bin path for hooks and will always run system python
diff --git a/setup.py b/setup.py
index 6b3175d..077e016 100755
--- a/setup.py
+++ b/setup.py
@@ -59,11 +59,11 @@ tests_require = [
'Django>=1.4',
'django-celery>=2.5',
'exam>=0.5.2',
- 'flake8>=2.0,<2.1',
+ 'flake8>=2.6,<2.7',
'logbook',
'mock',
'nose',
- 'pep8',
+ 'pycodestyle',
'pytz',
'pytest',
'pytest-django==2.9.1',