summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshley Camba <ashwoods@gmail.com>2018-02-14 20:59:48 +0100
committerGitHub <noreply@github.com>2018-02-14 20:59:48 +0100
commitf579e6809b01d27da5fe515d8572b497c98b4b43 (patch)
tree1c865ef62195789da78ea65a4eeecc7ac929aac1
parentf2aec528686db568c26a3e34d9c657236ab47ad7 (diff)
downloadraven-f579e6809b01d27da5fe515d8572b497c98b4b43.tar.gz
Add tag and remove releases from deploy pipeline (#1200)6.6.0
* Add tag and remove releases from deploy pipeline * build: Switch to Zeus and build every master commit
-rw-r--r--.travis.yml24
1 files changed, 12 insertions, 12 deletions
diff --git a/.travis.yml b/.travis.yml
index 1e2bcbd..5bab4d9 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -11,7 +11,6 @@ branches:
only:
- master
- /^(?i:feature)-.*$/
- - /^(?i:releases)\/.*$/
jobs:
fast_finish: true
# allow_failures:
@@ -130,16 +129,9 @@ jobs:
script: ./setup.py sdist --formats=gztar bdist_wheel
if: branch = master
python: 2.7
- deploy:
- provider: s3
- access_key_id: AKIAJKYWAF3QS7SFL75Q
- secret_access_key:
- secure: HFlh3wzzYIbkIYRt+Qu60ak0U1+RFagr3nI+EqX/9KJH0zwLg/Xv1Gfx4vZZ+0VZkeJIbZZC5l4HxUzFwkROepxPh0Foifqm7hRKL4HUBdvIONcW+h3Ilanvyj/0tIyRdFPK5pZ22qc+1nsARy0eYEtz/YQeEhiEohvNxbhOuUQ=
- skip_cleanup: true
- acl: public_read
- bucket: getsentry-builds
- upload-dir: $TRAVIS_REPO_SLUG/$TRAVIS_COMMIT
- local_dir: dist
+ after_success:
+ - npm install -g @zeus-ci/cli
+ - zeus upload -t "application/zip+wheel" dist/*
script: tox
install:
@@ -150,4 +142,12 @@ before_script:
after_success:
- codecov -e DJANGO
-
+notifications:
+ webhooks:
+ urls:
+ - https://zeus.ci/hooks/0b589ca4-1165-11e8-b03b-0a580a28023f/public/provider/travis/webhook
+ on_success: always
+ on_failure: always
+ on_start: always
+ on_cancel: always
+ on_error: always