summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshley Camba <ashwoods@gmail.com>2017-10-26 11:18:18 +0200
committerGitHub <noreply@github.com>2017-10-26 11:18:18 +0200
commit908148c1e159406c2c2cede9404887b042f19ec1 (patch)
treed7c0695a8c0bb5564cecf2ce9e7e91545c04134d
parent17a274e5d982f7bbf1592b854650274c55964fe0 (diff)
downloadraven-908148c1e159406c2c2cede9404887b042f19ec1.tar.gz
Add bumpversion config (#1115)
* Add bumpversion config
-rw-r--r--.bumpversion.cfg18
-rwxr-xr-xsetup.py4
-rw-r--r--tox.ini20
3 files changed, 36 insertions, 6 deletions
diff --git a/.bumpversion.cfg b/.bumpversion.cfg
new file mode 100644
index 0000000..58747dc
--- /dev/null
+++ b/.bumpversion.cfg
@@ -0,0 +1,18 @@
+[bumpversion]
+commit = False
+tag = False
+tag_name = {new_version}
+current_version = 6.3.0
+parse = (?P<major>\d+)\.(?P<minor>\d+)\.(?P<patch>\d+)(\.(?P<release>[a-z]+)(?P<dev>\d+))?
+serialize =
+ {major}.{minor}.{patch}.{release}{dev}
+ {major}.{minor}.{patch}
+message = Release: {current_version} → {new_version}
+
+[bumpversion:file:raven/__init__.py]
+
+[bumpversion:part:release]
+optional_value = production
+values =
+ dev
+ production
diff --git a/setup.py b/setup.py
index 2343933..ff34b21 100755
--- a/setup.py
+++ b/setup.py
@@ -60,7 +60,7 @@ tests_require = [
'bottle',
'celery>=2.5',
'exam>=0.5.2',
- 'flake8==3.4.1',
+ 'flake8==3.5.0',
'logbook',
'mock',
'nose',
@@ -73,7 +73,7 @@ tests_require = [
'pytest-sugar==0.8',
'pytest-assume',
'pytest-cov',
- 'pytest-flake8',
+ 'pytest-flake8==0.9',
'requests',
'tornado>=4.1',
'webob',
diff --git a/tox.ini b/tox.ini
index ddb68ff..9604fb0 100644
--- a/tox.ini
+++ b/tox.ini
@@ -141,10 +141,22 @@ commands =
basepython = python3.5
skip_install = true
deps =
- {[testenv:build]deps}
- twine >= 1.9.1
+ bumpversion
commands =
- {[testenv:build]commands}
- twine upload --skip-existing dist/*
+ bumpversion --tag --commit {posargs} release
+[testenv:minor]
+basepython = python3.5
+skip_install = true
+deps =
+ bumpversion
+commands =
+ bumpversion --tag --commit {posargs} minor
+[testenv:dev]
+basepython = python3.5
+skip_install = true
+deps =
+ bumpversion
+commands =
+ bumpversion {posargs} --commit {posargs} patch