summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dancho <alexanderdancho@gmail.com>2018-05-02 12:45:37 -0400
committerAshley Camba <ashwoods@gmail.com>2018-05-06 14:55:41 +0200
commit0dc769abfb5f7821e2309f30494d94d9051cc903 (patch)
treec6e6c3c641a327e4741c5351bd0911b9ed69ba71
parent333feea39401a1e1ca11521f94891554dfe6d352 (diff)
downloadraven-0dc769abfb5f7821e2309f30494d94d9051cc903.tar.gz
Add blinker to Sanic dependencies.
Pulling 6.7.0 and trying to do, `from raven.contrib.sanic import Sentry`, I get the following traceback: ``` Traceback (most recent call last): File "application.py", line 1, in <module> from raven.contrib.sanic import Sentry File "/usr/local/lib/python3.6/site-packages/raven/contrib/sanic.py", line 13, in <module> import blinker ModuleNotFoundError: No module named 'blinker' ``` That's my bad. This should resolve that.
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 15cb7df..25e6909 100755
--- a/setup.py
+++ b/setup.py
@@ -61,7 +61,10 @@ if sys.version_info[0] == 3:
# If it's Python 3.5+, add Sanic packages.
if sys.version_info >= (3, 5):
- sanic_requires = ['sanic>=0.7.0', ]
+ sanic_requires = [
+ 'blinker>=1.1',
+ 'sanic>=0.7.0',
+ ]
sanic_tests_requires = ['aiohttp', ]
tests_require = [