summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Robenolt <matt@ydekproductions.com>2015-08-02 17:40:11 -0700
committerMatt Robenolt <matt@ydekproductions.com>2015-08-02 17:43:24 -0700
commit94fe2b3d9c40e80be79342fdb25237b1b97cac13 (patch)
treebe6169c9b75e6613099a1ef19ca62862b996785e
parent211845648260c25681e530cd239da7eb3ca9a2a4 (diff)
downloadraven-94fe2b3d9c40e80be79342fdb25237b1b97cac13.tar.gz
Add pytest-timeout to try and get travis to error faster on hanging
builds
-rw-r--r--.travis.yml2
-rwxr-xr-xsetup.py1
-rw-r--r--test-requirements.txt1
3 files changed, 3 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 7597da6..f005431 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -33,7 +33,7 @@ install:
script:
- "if [[ ${TRAVIS_PYTHON_VERSION} != 'pypy' ]]; then make lint; fi"
- - py.test tests/ --cov raven --cov-report term-missing
+ - py.test tests/ --cov raven --cov-report term-missing --timeout 10
matrix:
allow_failures:
diff --git a/setup.py b/setup.py
index 9a7d237..d2f51b2 100755
--- a/setup.py
+++ b/setup.py
@@ -66,6 +66,7 @@ tests_require = [
'pytest>=2.7.0,<2.8.0',
'pytest-cov>=1.4',
'pytest-django>=2.8.0,<2.7.0',
+ 'pytest-timeout==0.4',
'requests',
'tornado',
'webob',
diff --git a/test-requirements.txt b/test-requirements.txt
index 4925081..1484a81 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -1,2 +1,3 @@
pytest-django
+pytest-timeout
-e .[dev,tests]