summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Cramer <dcramer@gmail.com>2012-07-10 17:00:40 +0200
committerDavid Cramer <dcramer@gmail.com>2012-07-10 17:00:40 +0200
commit2e20359fce139df3653d2414ad721237ef08fc51 (patch)
tree5f0a6d3e233e08a00ef6f231c4038aec0db649e0
parent502b05bbee7530d1ebfa74e10fd92f4795ea5a43 (diff)
downloadraven-2e20359fce139df3653d2414ad721237ef08fc51.tar.gz
Switch to flake8 for pep8/lint
-rw-r--r--.travis.yml3
-rw-r--r--Makefile3
2 files changed, 2 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 2160f5d..1108243 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,8 +8,7 @@ env:
install:
- sudo apt-get install libevent-dev
- pip install Django==$DJANGO --use-mirrors
- - pip install pep8 --use-mirrors
- - pip install https://github.com/dcramer/pyflakes/tarball/master
+ - pip install flake8 --use-mirrors
- pip install -e . --use-mirrors
script:
- make test
diff --git a/Makefile b/Makefile
index 734a2e3..2674d9d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,5 @@
test:
- pep8 --exclude=migrations --ignore=E501,E225,E121,E123,E124,E125,E127,E128 raven || exit 1
- pyflakes -x W raven || exit 1
+ flake8 --exclude=migrations --ignore=E501,E225,E121,E123,E124,E125,E127,E128 --exit-zero raven
python setup.py test
coverage: