summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Cramer <dcramer@gmail.com>2012-07-13 19:36:06 -0700
committerDavid Cramer <dcramer@gmail.com>2012-07-13 19:36:06 -0700
commitd5075b92f4c113aa72da3d3945b2f78af6be0d4e (patch)
treec405e42224ecae2bd55d73f41f1696ba5e3a9d20
parentc1f09fa3794fd4ccb60a1f150cc573f5f3f29e37 (diff)
parentf19eeee462503414d914ae78147f30b86ab2bf2c (diff)
downloadraven-d5075b92f4c113aa72da3d3945b2f78af6be0d4e.tar.gz
Merge pull request #142 from do3cc/master
Apparently I screwed up and my manifest.in changes were missing. The 2.0.0 egg is missing a component.xml
-rw-r--r--.gitignore5
-rw-r--r--MANIFEST.in1
-rw-r--r--raven/handlers/logging.py3
3 files changed, 7 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index e8fdfe8..2b12a04 100644
--- a/.gitignore
+++ b/.gitignore
@@ -15,4 +15,7 @@ pip-log.txt
/docs/doctrees
/sentry_index/
/sentry_test_index
-/example_project/*.db \ No newline at end of file
+/example_project/*.db
+bin/
+include/
+lib/
diff --git a/MANIFEST.in b/MANIFEST.in
index 72623b5..b91b29b 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,2 +1,3 @@
include setup.py README.rst MANIFEST.in LICENSE
+recursive-include raven/contrib/zope *.xml
global-exclude *~
diff --git a/raven/handlers/logging.py b/raven/handlers/logging.py
index 19e1306..b8e19ef 100644
--- a/raven/handlers/logging.py
+++ b/raven/handlers/logging.py
@@ -92,7 +92,8 @@ class SentryHandler(logging.Handler, object):
if not started:
f_globals = getattr(frame, 'f_globals', {})
module_name = f_globals.get('__name__', '')
- if last_mod.startswith('logging') and not module_name.startswith('logging'):
+ if (last_mod and last_mod.startswith('logging')) \
+ and not module_name.startswith('logging'):
started = True
else:
last_mod = module_name