summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Arndt <arndtn@gmail.com>2021-03-01 13:38:31 +0100
committerNatanael Arndt <arndtn@gmail.com>2021-03-01 13:38:31 +0100
commitbb2ef1a5c67064a2c13ae4bfed21a4364436f1e5 (patch)
tree323316c34ecb3116252e38ce03fe461245a7bf1e
parentb7afa35faa3952a7b5a6fdfe47a01b91b774ff7d (diff)
downloadrdflib-bb2ef1a5c67064a2c13ae4bfed21a4364436f1e5.tar.gz
Move installation of coverage and nose-timer to requirements.dev.txt
-rw-r--r--.drone.yml9
-rw-r--r--.travis.yml3
-rw-r--r--requirements.dev.txt2
3 files changed, 10 insertions, 4 deletions
diff --git a/.drone.yml b/.drone.yml
index bbaf37ee..e40f9358 100644
--- a/.drone.yml
+++ b/.drone.yml
@@ -14,10 +14,11 @@ steps:
- bash .travis.fuseki_install_optional.sh
- pip install --default-timeout 60 -r requirements.txt
- pip install --default-timeout 60 -r requirements.dev.txt
- - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
+ - pip install --default-timeout 60 coveralls && export HAS_COVERALLS=1
- python setup.py install
- flake8 --exit-zero rdflib
- PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
+ - coverage report
---
kind: pipeline
@@ -34,10 +35,11 @@ steps:
- bash .travis.fuseki_install_optional.sh
- pip install --default-timeout 60 -r requirements.txt
- pip install --default-timeout 60 -r requirements.dev.txt
- - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
+ - pip install --default-timeout 60 coveralls && export HAS_COVERALLS=1
- python setup.py install
- flake8 --exit-zero rdflib
- PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
+ - coverage report
---
kind: pipeline
@@ -54,7 +56,8 @@ steps:
- bash .travis.fuseki_install_optional.sh
- pip install --default-timeout 60 -r requirements.txt
- pip install --default-timeout 60 -r requirements.dev.txt
- - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
+ - pip install --default-timeout 60 coveralls && export HAS_COVERALLS=1
- python setup.py install
- flake8 --exit-zero rdflib
- PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
+ - coverage report
diff --git a/.travis.yml b/.travis.yml
index 8f8d3385..0e28b1d4 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -29,7 +29,7 @@ before_install:
install:
- pip install --default-timeout 60 -r requirements.txt
- pip install --default-timeout 60 -r requirements.dev.txt
- - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
+ - pip install --default-timeout 60 coveralls && export HAS_COVERALLS=1
- python setup.py install
before_script:
@@ -37,6 +37,7 @@ before_script:
script:
- PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
+ - coverage report
after_success:
- if [[ $HAS_COVERALLS ]] ; then coveralls ; fi
diff --git a/requirements.dev.txt b/requirements.dev.txt
index 059a4e9e..77fda028 100644
--- a/requirements.dev.txt
+++ b/requirements.dev.txt
@@ -1,5 +1,7 @@
sphinx
sphinxcontrib-apidoc
nose==1.3.7
+nose-timer
+coverage
flake8
doctest-ignore-unicode==0.1.2