summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIwan Aucamp <aucampia@gmail.com>2022-07-13 13:46:28 +0200
committerGitHub <noreply@github.com>2022-07-13 13:46:28 +0200
commit512b9b3ab6c264731c17409802fe98fb85825fd9 (patch)
treeffa645057f792db9a6569be1664a4a5ebf20f4d0
parent7b282594cbecd1c91f2b6295f8eb20fdb19ffc29 (diff)
downloadrdflib-512b9b3ab6c264731c17409802fe98fb85825fd9.tar.gz
Update black to 22.6.0 (#2015)
Update black to 22.6.0 in all places where the version is specified to ensure we are using the latest version.
-rw-r--r--.pre-commit-config.yaml2
-rw-r--r--docs/developers.rst2
-rw-r--r--pyproject.toml2
-rw-r--r--requirements.dev.txt2
-rw-r--r--setup.py2
5 files changed, 5 insertions, 5 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 5589bfd7..5aa19840 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -16,7 +16,7 @@ repos:
args: ["."]
- repo: https://github.com/psf/black
# WARNING: version should be the same as in `pyproject.toml` and `requirements.dev.txt`.
- rev: 'refs/tags/22.3.0:refs/tags/22.3.0'
+ rev: 'refs/tags/22.6.0:refs/tags/22.6.0'
hooks:
- id: black
pass_filenames: false
diff --git a/docs/developers.rst b/docs/developers.rst
index 8fb181f5..aac57d8c 100644
--- a/docs/developers.rst
+++ b/docs/developers.rst
@@ -10,7 +10,7 @@ This document describes the process and conventions to follow when
developing RDFLib code.
* Please be as Pythonic as possible (:pep:`8`).
-* Code should be formatted using `black <https://github.com/psf/black>`_ and we use Black v22.3.0, with the black config in ``pyproject.toml``.
+* Code should be formatted using `black <https://github.com/psf/black>`_ and we use Black v22.6.0, with the black config in ``pyproject.toml``.
* Code should also pass `flake8 <https://flake8.pycqa.org/en/latest/>`_ linting
and `mypy <http://mypy-lang.org/>`_ type checking.
* You must supply tests for new code.
diff --git a/pyproject.toml b/pyproject.toml
index 2b6869b4..48672b0a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -30,7 +30,7 @@ pep8-naming = ["-N815"]
[tool.black]
-required-version = "22.3.0"
+required-version = "22.6.0"
line-length = "88"
target-version = ['py37']
include = '\.pyi?$'
diff --git a/requirements.dev.txt b/requirements.dev.txt
index 0526f595..3cbf4da6 100644
--- a/requirements.dev.txt
+++ b/requirements.dev.txt
@@ -1,4 +1,4 @@
-black==22.3.0
+black==22.6.0
coverage
doctest-ignore-unicode==0.1.2
html5lib
diff --git a/setup.py b/setup.py
index ebaf7ff5..45eac275 100644
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,7 @@ kwargs["extras_require"] = {
"berkeleydb": ["berkeleydb"],
"networkx": ["networkx"],
"dev": [
- "black==22.3.0",
+ "black==22.6.0",
"flake8",
"flakeheaven; python_version >= '3.8.0'",
"isort",