summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Car <nicholas.car@surroundaustralia.com>2020-10-03 22:09:38 +1000
committerNicholas Car <nicholas.car@surroundaustralia.com>2020-10-03 22:09:38 +1000
commitf473263be52db516816eeb654d8b5df2fca3486e (patch)
tree96bba0908ee67b482285326a15632100b2eaa2e3
parent67b805873b2cdf85bc4ab3859200a2abc2289aff (diff)
downloadrdflib-f473263be52db516816eeb654d8b5df2fca3486e.tar.gz
updated to support Python 3.6+ only (not 3.5)
-rw-r--r--.travis.yml2
-rw-r--r--README.md2
-rw-r--r--docs/developers.rst2
-rw-r--r--setup.py3
4 files changed, 4 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index 848aebc2..33536b1a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,9 +9,9 @@ git:
depth: 3
python:
- - 3.5
- 3.6
- 3.7
+ - 3.8
jobs:
include:
diff --git a/README.md b/README.md
index 5de6e79c..6e3e6a8b 100644
--- a/README.md
+++ b/README.md
@@ -31,7 +31,7 @@ Please see the list for all packages/repositories here:
## Versions
* `5.x.y` supports Python 2.7 and 3.4+ and is [mostly backwards compatible with 4.2.2](https://rdflib.readthedocs.io/en/stable/upgrade4to5.html). Only bug fixes will be applied.
- * `6.x.y` is the next major release which will support Python 3.5+. (Current master branch)
+ * `6.x.y` is the next major release which will support Python 3.6+. (Current master branch)
## Installation
diff --git a/docs/developers.rst b/docs/developers.rst
index d05139f7..d31a5e54 100644
--- a/docs/developers.rst
+++ b/docs/developers.rst
@@ -59,7 +59,7 @@ Compatibility
RDFLib 5.x.y tries to be compatible with python versions 2.7, 3.4, 3.5, 3.6, 3.7.
-The current master branch (which will be released as 6.0.0) will only support Python 3.5 and newer.
+The current master branch (which will be released as 6.0.0) will only support Python 3.6 and newer.
Releasing
diff --git a/setup.py b/setup.py
index 969f5fe0..8dd82c2b 100644
--- a/setup.py
+++ b/setup.py
@@ -49,11 +49,10 @@ setup(
url="https://github.com/RDFLib/rdflib",
license="BSD-3-Clause",
platforms=["any"],
- python_requires=">=3.5",
+ python_requires=">=3.6",
classifiers=[
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",