summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Arndt <arndtn@gmail.com>2021-01-28 12:35:23 +0100
committerNatanael Arndt <arndtn@gmail.com>2021-01-28 12:35:26 +0100
commitd4f3a98294e07d4d90c62c639103732d3d5b3b30 (patch)
treef38e1e3e7e7e2fe55ef1f8c66c68b8376c318663
parent8e3c771a5c6a2787b5a34a9288c7d5d6967ecbbe (diff)
downloadrdflib-d4f3a98294e07d4d90c62c639103732d3d5b3b30.tar.gz
Move flake8 config
remove .pep8 as we don't use it move the pep8 configuration to setup.cfg set line length to the default value of black, as we use black adjust travis configuration
-rw-r--r--.pep84
-rw-r--r--.travis.yml2
-rw-r--r--setup.cfg5
3 files changed, 6 insertions, 5 deletions
diff --git a/.pep8 b/.pep8
deleted file mode 100644
index acc7b2d3..00000000
--- a/.pep8
+++ /dev/null
@@ -1,4 +0,0 @@
-[pep8]
-ignore = W806
-max-line-length = 85
-exclude = host,extras,transform,rdfs
diff --git a/.travis.yml b/.travis.yml
index c8cf3a5d..8f8d3385 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -33,7 +33,7 @@ install:
- python setup.py install
before_script:
- - flake8 --exclude=pyRdfa,extras,host,transform,rdfs,sparql,results,pyMicrodata --exit-zero rdflib
+ - flake8 --exit-zero rdflib
script:
- PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
diff --git a/setup.cfg b/setup.cfg
index 535ee310..cc063e11 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -6,3 +6,8 @@ with-doctest=1
with-doctest-ignore-unicode=1
doctest-options=+IGNORE_UNICODE
exclude=rdflib.plugins.sparql.paths|rdflib.extras.external_graph_libs
+
+[flake8]
+ignore = W806
+max-line-length = 88
+exclude = host,extras,transform,rdfs,pyRdfa,sparql,results,pyMicrodata