summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Car <nicholas.car@surroundaustralia.com>2021-07-20 23:46:28 +1000
committerNicholas Car <nicholas.car@surroundaustralia.com>2021-07-20 23:46:28 +1000
commit038af4547e799845e08986867b24acafcbe72d48 (patch)
treec97825d6a635ed61e07b8e9b3e4501dd02691948
parent17969dccdc6b182ef19c1a9e0b86a6585026aeab (diff)
downloadrdflib-038af4547e799845e08986867b24acafcbe72d48.tar.gz
6.0.0a0: simplify license for GitHub to recognise, setup.py long desk from README.md
-rw-r--r--LICENSE44
-rw-r--r--README.md4
-rw-r--r--admin/README.md26
-rw-r--r--rdflib/__init__.py4
-rw-r--r--setup.py40
5 files changed, 65 insertions, 53 deletions
diff --git a/LICENSE b/LICENSE
index 76f24d5b..23cc5723 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,33 +1,29 @@
-LICENSE AGREEMENT FOR RDFLIB
-------------------------------------------------
+BSD 3-Clause License
+
Copyright (c) 2002-2021, RDFLib Team
-See CONTRIBUTORS and http://github.com/RDFLib/rdflib
All rights reserved.
Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are
-met:
+modification, are permitted provided that the following conditions are met:
- * Redistributions of source code must retain the above copyright
-notice, this list of conditions and the following disclaimer.
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
- * Redistributions in binary form must reproduce the above
-copyright notice, this list of conditions and the following
-disclaimer in the documentation and/or other materials provided
-with the distribution.
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
- * Neither the name of Daniel Krech nor the names of its
-contributors may be used to endorse or promote products derived
-from this software without specific prior written permission.
+3. Neither the name of the copyright holder nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/README.md b/README.md
index e426997f..4ccd176a 100644
--- a/README.md
+++ b/README.md
@@ -30,8 +30,8 @@ Please see the list for all packages/repositories here:
## Versions & Releases
* `6.0.1-alpha` current `master` branch
- * `6.x.y` current release and support Python 3.7+ only. Many improvements over 5.0.0
- * `5.x.y` supports Python 2.7 and 3.4+ and is [mostly backwards compatible with 4.2.2](https://rdflib.readthedocs.io/en/stable/upgrade4to5.html).
+* `6.x.y` current release and support Python 3.7+ only. Many improvements over 5.0.0
+* `5.x.y` supports Python 2.7 and 3.4+ and is [mostly backwards compatible with 4.2.2](https://rdflib.readthedocs.io/en/stable/upgrade4to5.html).
See <https://rdflib.dev> for the release schedule.
diff --git a/admin/README.md b/admin/README.md
index bc26ef6e..67d27a2d 100644
--- a/admin/README.md
+++ b/admin/README.md
@@ -2,3 +2,29 @@
Tools to assist with RDFlib releases, like extracting all merged PRs from GitHub since last release.
+
+## Release procedure
+
+1. merge all PRs for the release
+1. pass all tests
+1. black everything
+ * use the config, e.g. `black --config black.toml .` in main dir
+1. build docs - check for errors/warnings there
+1. alter version & date in rdflib/__init__.py
+1. update:
+ * CHANGELOG.md
+ * CONTRIBUTORS
+ * use scripts here to generate "PRs since last release"
+ * LICENSE (the date)
+ * setup.py (the long description)
+1. update admin steps (here)
+1. push to PyPI
+ * `pip3 install twine wheel`
+ * `python3 setup.py bdist_wheel sdist`
+ * `twine upload ./dist/*`
+1. Make GitHub release
+ * go to the taged version, e.g. https://github.com/RDFLib/rdflib/releases/tag/6.0.0
+ * edit the release' notes there (likely copy from CHANGELOG)
+1. Build readthedocs docco
+ * `latest` and `stable` need to be built at least
+ * best to make sure the previous (outgoing) release has a number-pegged version, e.g. 5.0.0
diff --git a/rdflib/__init__.py b/rdflib/__init__.py
index 27394b43..c9163d14 100644
--- a/rdflib/__init__.py
+++ b/rdflib/__init__.py
@@ -45,8 +45,8 @@ A tiny example:
__docformat__ = "restructuredtext en"
# The format of the __version__ line is matched by a regex in setup.py
-__version__ = "6.0.0"
-__date__ = "2021-07-20"
+__version__ = "6.0.1a0"
+__date__ = "2021-07-21"
__all__ = [
"URIRef",
diff --git a/setup.py b/setup.py
index 0496a432..a769b255 100644
--- a/setup.py
+++ b/setup.py
@@ -2,6 +2,7 @@
import os
import re
+import codecs
from setuptools import setup, find_packages
kwargs = {}
@@ -32,6 +33,17 @@ def find_version(filename):
return version_match.group(1)
+def open_local(paths, mode='r', encoding='utf8'):
+ path = os.path.join(
+ os.path.abspath(os.path.dirname(__file__)),
+ *paths
+ )
+ return codecs.open(path, mode, encoding)
+
+
+with open_local(['README.md'], encoding='utf-8') as readme:
+ long_description = readme.read()
+
version = find_version("rdflib/__init__.py")
packages = find_packages(exclude=("examples*", "test*"))
@@ -51,7 +63,7 @@ setup(
maintainer="RDFLib Team",
maintainer_email="rdflib-dev@googlegroups.com",
url="https://github.com/RDFLib/rdflib",
- license="BSD-3-Clause",
+ license="bsd-3-clause",
platforms=["any"],
python_requires=">=3.7",
classifiers=[
@@ -65,30 +77,8 @@ setup(
"Operating System :: OS Independent",
"Natural Language :: English",
],
- long_description="""\
-RDFLib is a Python library for working with
-RDF, a simple yet powerful language for representing information.
-
-The library contains parsers and serializers for RDF/XML, N3,
-NTriples, Turtle, TriX, JSON-LD, RDFa and Microdata . The library
-presents a Graph interface which can be backed by any one of a
-number of Store implementations. The core rdflib includes store
-implementations for in memory storage, persistent storage on top
-of the Berkeley DB, and a wrapper for remote SPARQL endpoints.
-
-A SPARQL 1.1 engine is also included.
-
-If you have recently reported a bug marked as fixed, or have a craving for
-the very latest, you may want the development version instead:
-
- pip install git+https://github.com/rdflib/rdflib
-
-
-Read the docs at:
-
- http://rdflib.readthedocs.io
-
- """,
+ long_description=long_description,
+ long_description_content_type="text/markdown",
packages=packages,
entry_points={
"console_scripts": [