summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbescoto <bescoto@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2003-09-12 02:51:57 +0000
committerbescoto <bescoto@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2003-09-12 02:51:57 +0000
commit9d2c911ef7763ac7f2123878c002a059f2826708 (patch)
tree8c5a3cf578cf008354f7978e122e91ec7e14dd00
parent8195a11884a64a4959724142bf6e45fa64ff634c (diff)
downloadrdiff-backup-9d2c911ef7763ac7f2123878c002a059f2826708.tar.gz
New rdiff-backup spec template for Fedora
git-svn-id: http://svn.savannah.nongnu.org/svn/rdiff-backup/trunk@428 2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109
-rw-r--r--rdiff-backup/dist/rdiff-backup.spec.template-fedora53
1 files changed, 53 insertions, 0 deletions
diff --git a/rdiff-backup/dist/rdiff-backup.spec.template-fedora b/rdiff-backup/dist/rdiff-backup.spec.template-fedora
new file mode 100644
index 0000000..3f77b72
--- /dev/null
+++ b/rdiff-backup/dist/rdiff-backup.spec.template-fedora
@@ -0,0 +1,53 @@
+%define PYTHON_VERSION %(python -c 'import sys; sys.stdout.write(".".join(map(str,sys.version_info[:2])))')
+%define NEXT_PYTHON_VERSION %(python -c 'import sys; sys.stdout.write(str(sys.version_info[0])); sys.stdout.write("."); sys.stdout.write(str(sys.version_info[1]+1))')
+
+Version: $version
+Summary: Convenient and transparent local/remote incremental mirror/backup
+Name: rdiff-backup
+Release: 0.fdr.1
+Epoch: 0
+URL: http://rdiff-backup.stanford.edu/
+Source: http://rdiff-backup.stanford.edu/OLD/%{version}/%{name}-%{version}.tar.gz
+License: GPL
+Group: Applications/Archiving
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Requires: python >= %{PYTHON_VERSION}, python < %{NEXT_PYTHON_VERSION}
+BuildRequires: python-devel >= 0:2.2, librsync-devel
+
+%description
+rdiff-backup is a script, written in Python, that backs up one
+directory to another and is intended to be run periodically (nightly
+from cron for instance). The target directory ends up a copy of the
+source directory, but extra reverse diffs are stored in the target
+directory, so you can still recover files lost some time ago. The idea
+is to combine the best features of a mirror and an incremental
+backup. rdiff-backup can also operate in a bandwidth efficient manner
+over a pipe, like rsync. Thus you can use rdiff-backup and ssh to
+securely back a hard drive up to a remote location, and only the
+differences from the previous backup will be transmitted.
+
+%prep
+%setup -q
+
+%build
+python setup.py build
+
+%install
+python setup.py install --root $RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root)
+%{_bindir}/rdiff-backup
+%{_mandir}/man1/rdiff-backup*
+%{_libdir}/python%{PYTHON_VERSION}/site-packages/rdiff_backup
+%doc CHANGELOG COPYING FAQ.html examples.html README
+
+%changelog
+* Thu Aug 16 2003 Ben Escoto <bescoto@stanford.edu> - 0:0.12.3-0.fdr.4
+- Implemented various suggestions of Fedora QA
+
+* Sun Nov 4 2001 Ben Escoto <bescoto@stanford.edu>
+- Initial RPM