summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcvs2svn <cvs2svn@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2002-09-16 17:02:41 +0000
committercvs2svn <cvs2svn@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2002-09-16 17:02:41 +0000
commitde25c3e2f032d0d2fb1355e8c38de3e7607e8443 (patch)
tree9395cf32fc2fad3886956ecdbf37e3ceaa7740f1
parent9d9276ef4205aef4b2ca8b5c8ecba86829845486 (diff)
downloadrdiff-backup-r0-10-0.tar.gz
This commit was manufactured by cvs2svn to create tag 'r0-10-0'.r0-10-0
git-svn-id: http://svn.savannah.nongnu.org/svn/rdiff-backup/tags/r0-10-0@206 2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109
-rw-r--r--rdiff-backup/CHANGELOG7
-rwxr-xr-xrdiff-backup/dist/setup.py5
-rwxr-xr-xrdiff-backup/rdiff-backup2
-rw-r--r--rdiff-backup/rdiff_backup/cmodule.c4
-rwxr-xr-xrdiff-backup/rdiff_backup/compilec.py5
-rw-r--r--rdiff-backup/src/cmodule.c4
-rwxr-xr-xrdiff-backup/src/compilec.py5
7 files changed, 10 insertions, 22 deletions
diff --git a/rdiff-backup/CHANGELOG b/rdiff-backup/CHANGELOG
index 58774a4..c24c652 100644
--- a/rdiff-backup/CHANGELOG
+++ b/rdiff-backup/CHANGELOG
@@ -1,10 +1,3 @@
-New in v0.10.1 (2002/09/16)
----------------------------
-
-rdiff-backup should now correctly handle files larger than 2GB.
-Thanks to Russ Allbery for telling me how to do this.
-
-
New in v0.10.0 (2002/09/10)
---------------------------
diff --git a/rdiff-backup/dist/setup.py b/rdiff-backup/dist/setup.py
index 6841b6d..cb571cd 100755
--- a/rdiff-backup/dist/setup.py
+++ b/rdiff-backup/dist/setup.py
@@ -16,10 +16,7 @@ setup(name="rdiff-backup",
author_email="bescoto@stanford.edu",
url="http://rdiff-backup.stanford.edu",
packages = ['rdiff_backup'],
- ext_modules = [Extension("rdiff_backup.C", ["cmodule.c"],
- define_macros=[("_LARGEFILE_SOURCE", 1),
- ("_FILE_OFFSET_BITS", 64),
- ("_LARGE_FILES", 1)]),
+ ext_modules = [Extension("rdiff_backup.C", ["cmodule.c"]),
Extension("rdiff_backup._librsync",
["_librsyncmodule.c"],
libraries=["rsync"])],
diff --git a/rdiff-backup/rdiff-backup b/rdiff-backup/rdiff-backup
index a169a43..af10c93 100755
--- a/rdiff-backup/rdiff-backup
+++ b/rdiff-backup/rdiff-backup
@@ -1,6 +1,6 @@
#!/usr/bin/env python
# rdiff-backup -- Mirror files while keeping incremental changes
-# Version $version released September 16, 2002
+# Version $version released August 9, 2002
# Copyright (C) 2001, 2002 Ben Escoto <bescoto@stanford.edu>
#
# This program is licensed under the GNU General Public License (GPL).
diff --git a/rdiff-backup/rdiff_backup/cmodule.c b/rdiff-backup/rdiff_backup/cmodule.c
index 47a675f..d4787ed 100644
--- a/rdiff-backup/rdiff_backup/cmodule.c
+++ b/rdiff-backup/rdiff_backup/cmodule.c
@@ -32,6 +32,8 @@
# define STRUCT_STAT struct stat
#endif
+extern int lstat(const char *, struct stat *);
+
static PyObject *UnknownFileTypeError;
static PyObject *c_make_file_dict(PyObject *self, PyObject *args);
static PyObject *long2str(PyObject *self, PyObject *args);
@@ -46,7 +48,7 @@ static PyObject *c_make_file_dict(self, args)
{
PyObject *size, *inode, *mtime, *atime, *devloc, *return_val;
char *filename, filetype[5];
- STRUCT_STAT sbuf;
+ struct stat sbuf;
long int mode, perms;
int res;
diff --git a/rdiff-backup/rdiff_backup/compilec.py b/rdiff-backup/rdiff_backup/compilec.py
index 4714cf3..696d351 100755
--- a/rdiff-backup/rdiff_backup/compilec.py
+++ b/rdiff-backup/rdiff_backup/compilec.py
@@ -9,10 +9,7 @@ sys.argv.append("build")
setup(name="CModule",
version="0.9.0",
description="rdiff-backup's C component",
- ext_modules=[Extension("C", ["cmodule.c"],
- define_macros=[("_LARGEFILE_SOURCE", 1),
- ("_FILE_OFFSET_BITS", 64),
- ("_LARGE_FILES", 1)]),
+ ext_modules=[Extension("C", ["cmodule.c"]),
Extension("_librsync",
["_librsyncmodule.c"],
libraries=["rsync"])])
diff --git a/rdiff-backup/src/cmodule.c b/rdiff-backup/src/cmodule.c
index 47a675f..d4787ed 100644
--- a/rdiff-backup/src/cmodule.c
+++ b/rdiff-backup/src/cmodule.c
@@ -32,6 +32,8 @@
# define STRUCT_STAT struct stat
#endif
+extern int lstat(const char *, struct stat *);
+
static PyObject *UnknownFileTypeError;
static PyObject *c_make_file_dict(PyObject *self, PyObject *args);
static PyObject *long2str(PyObject *self, PyObject *args);
@@ -46,7 +48,7 @@ static PyObject *c_make_file_dict(self, args)
{
PyObject *size, *inode, *mtime, *atime, *devloc, *return_val;
char *filename, filetype[5];
- STRUCT_STAT sbuf;
+ struct stat sbuf;
long int mode, perms;
int res;
diff --git a/rdiff-backup/src/compilec.py b/rdiff-backup/src/compilec.py
index 4714cf3..696d351 100755
--- a/rdiff-backup/src/compilec.py
+++ b/rdiff-backup/src/compilec.py
@@ -9,10 +9,7 @@ sys.argv.append("build")
setup(name="CModule",
version="0.9.0",
description="rdiff-backup's C component",
- ext_modules=[Extension("C", ["cmodule.c"],
- define_macros=[("_LARGEFILE_SOURCE", 1),
- ("_FILE_OFFSET_BITS", 64),
- ("_LARGE_FILES", 1)]),
+ ext_modules=[Extension("C", ["cmodule.c"]),
Extension("_librsync",
["_librsyncmodule.c"],
libraries=["rsync"])])