summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbescoto <bescoto@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2003-08-08 22:59:06 +0000
committerbescoto <bescoto@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2003-08-08 22:59:06 +0000
commit22feccffb1547536de23a5de76e5b73ad1bdd370 (patch)
tree7350e14864ee073520b68592a1b528fab75438fe
parenta825a73a0f7bf62f8aac714ca0189acad53360af (diff)
downloadrdiff-backup-22feccffb1547536de23a5de76e5b73ad1bdd370.tar.gz
Final changes for 0.12.3
git-svn-id: http://svn.savannah.nongnu.org/svn/rdiff-backup/branches/r0-12@387 2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109
-rw-r--r--rdiff-backup/CHANGELOG7
-rwxr-xr-xrdiff-backup/dist/makerpm10
-rw-r--r--rdiff-backup/dist/rdiff-backup.spec.template13
-rw-r--r--rdiff-backup/rdiff_backup/_librsyncmodule.c2
4 files changed, 18 insertions, 14 deletions
diff --git a/rdiff-backup/CHANGELOG b/rdiff-backup/CHANGELOG
index 03640c2..d8aafd1 100644
--- a/rdiff-backup/CHANGELOG
+++ b/rdiff-backup/CHANGELOG
@@ -1,4 +1,4 @@
-New in v0.12.3 (2003/08/??)
+New in v0.12.3 (2003/08/08)
---------------------------
Patch by Jeffrey Marshall fixes socket/fifo recognition on Mac OS X
@@ -10,6 +10,11 @@ to have broken recently.
rdiff-backup should now work with python 2.3. Thanks to Arkadiusz
Miskiewicz for bug reports.
+rdiff-backup now builds with and requires librsync 0.9.6. This
+version should be much better than the old one and everyone should
+probably upgrade. Much thanks to Donovan Baarda for all the work that
+went into this release.
+
New in v0.12.2 (2003/07/24)
---------------------------
diff --git a/rdiff-backup/dist/makerpm b/rdiff-backup/dist/makerpm
index bdc3060..29fd415 100755
--- a/rdiff-backup/dist/makerpm
+++ b/rdiff-backup/dist/makerpm
@@ -1,20 +1,20 @@
#!/usr/bin/env python
-import os, sys, re
+import os, sys
-rpmroot = "/home/ben/rpm"
+rpmroot = os.path.join(os.environ['HOME'], 'rpm')
if len(sys.argv) == 2:
- version = sys.argv[1]
+ Version = sys.argv[1]
specfile = "rdiff-backup.spec"
print "Using specfile %s" % specfile
else:
print "Syntax: %s version_number" % sys.argv[0]
sys.exit(1)
-base = "rdiff-backup-%s" % (version,)
+base = "rdiff-backup-%s" % (Version,)
tarfile = base + ".tar.gz"
-rpmbase = base + "-0.fdr.2" # Fedora suffix, with release number 2
+rpmbase = base + "-0.fdr.3" # Fedora suffix, with release number 1
i386_rpm = rpmbase + ".i386.rpm"
source_rpm = rpmbase + ".src.rpm"
diff --git a/rdiff-backup/dist/rdiff-backup.spec.template b/rdiff-backup/dist/rdiff-backup.spec.template
index 47c2ce7..28cbf51 100644
--- a/rdiff-backup/dist/rdiff-backup.spec.template
+++ b/rdiff-backup/dist/rdiff-backup.spec.template
@@ -3,15 +3,15 @@
Version: $version
Summary: Convenient and transparent local/remote incremental mirror/backup
Name: rdiff-backup
-Release: 0.fdr.2
+Release: 0.fdr.3
Epoch: 0
URL: http://rdiff-backup.stanford.edu/
-Source: http://rdiff-backup.stanford.edu/%{name}-%{version}.tar.gz
+Source: http://rdiff-backup.stanford.edu/OLD/%{version}/%{name}-%{version}.tar.gz
License: GPL
Group: Applications/Archiving
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-Requires: librsync >= 0.9.5.1, %{PYTHON_NAME} >= 2.2
-BuildPrereq: %{PYTHON_NAME}-devel >= 2.2, librsync-devel = 0.9.5.1
+Requires: librsync >= 0.9.6, %{PYTHON_NAME} >= 2.2
+BuildPrereq: %{PYTHON_NAME}-devel >= 2.2, librsync-devel >= 0.9.6
%description
rdiff-backup is a script, written in Python, that backs up one
@@ -45,9 +45,8 @@ differences from the previous backup will be transmitted.
%doc CHANGELOG COPYING FAQ.html README
%changelog
-* Thu Jul 24 2003 Ben Escoto <bescoto@stanford.edu>
-- Set librsync = 0.9.5.1, because new version will use librsync.h
- instead of rsync.h
+* Thu Aug 8 2003 Ben Escoto <bescoto@stanford.edu>
+- Set librsync >= 0.9.6, because rsync.h renamed to librsync.h
* Sun Jul 20 2003 Ben Escoto <bescoto@stanford.edu>
- Minor changes to comply with Fedora standards.
diff --git a/rdiff-backup/rdiff_backup/_librsyncmodule.c b/rdiff-backup/rdiff_backup/_librsyncmodule.c
index 92a31f0..d3aaf5c 100644
--- a/rdiff-backup/rdiff_backup/_librsyncmodule.c
+++ b/rdiff-backup/rdiff_backup/_librsyncmodule.c
@@ -22,7 +22,7 @@
* ----------------------------------------------------------------------- */
#include <Python.h>
-#include <rsync.h>
+#include <librsync.h>
#define RS_JOB_BLOCKSIZE 65536
static PyObject *librsyncError;