summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorben <ben@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2002-06-17 07:59:31 +0000
committerben <ben@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2002-06-17 07:59:31 +0000
commit9e4b8b40f80eef0a785ed73d95c99cfd54478fd8 (patch)
tree8060549a32213ab0f023d18358868d040fcc8219
parentb4df2b8231ea724cb208d26eced159c7ddb4e0c2 (diff)
downloadrdiff-backup-9e4b8b40f80eef0a785ed73d95c99cfd54478fd8.tar.gz
Distribution changes for new exploded format
git-svn-id: http://svn.savannah.nongnu.org/svn/rdiff-backup/trunk@137 2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109
-rwxr-xr-xrdiff-backup/dist/makedist37
-rwxr-xr-xrdiff-backup/dist/makerpm27
-rw-r--r--rdiff-backup/dist/rdiff-backup.spec15
-rwxr-xr-xrdiff-backup/dist/setup.py28
4 files changed, 60 insertions, 47 deletions
diff --git a/rdiff-backup/dist/makedist b/rdiff-backup/dist/makedist
index bba7d23..b7430ab 100755
--- a/rdiff-backup/dist/makedist
+++ b/rdiff-backup/dist/makedist
@@ -4,9 +4,6 @@ import os, re, shutil, time
SourceDir = "src"
DistDir = "dist"
-filelist = [SourceDir + "/rdiff-backup", "CHANGELOG",
- "COPYING", "README", "FAQ.html"]
-
# Various details about the files must also be specified by the rpm
# spec template.
@@ -20,22 +17,6 @@ def GetVersion():
fp.close()
return match.group(1)
-def CopyModule():
- """Copy all the relevant module source files to rdiff_backup"""
- moddir = DistDir+"/rdiff_backup"
- os.system("rm -rf %s" % moddir)
- os.mkdir(moddir)
-
- for filename in ["cmodule.c", "connection.py", "destructive_stepping.py",
- "FilenameMapping.py", "Globals.py", "Hardlink.py",
- "highlevel.py", "increment.py", "__init__.py",
- "iterfile.py", "lazy.py", "log.py", "Main.py",
- "manage.py", "MiscStats.py", "Rdiff.py", "restore.py",
- "rlist.py", "robust.py", "rorpiter.py", "rpath.py",
- "seleciton.py", "SetConnections.py", "static.py",
- "statistics.py", "Time.py"]:
- assert not os.system("cp %s/%s %s" % (SourceDir, filename, moddir))
-
def CopyMan(destination, version):
"""Create updated man page at the specified location"""
fp = open(destination, "w")
@@ -93,7 +74,23 @@ def MakeTar(version):
os.system("rm -rf " + tardir)
except OSError: pass
os.mkdir(tardir)
- for file in filelist: os.system("cp -a %s %s" % (file, tardir))
+ for filename in ["rdiff-backup", "CHANGELOG", "COPYING",
+ "README", "FAQ.html", SourceDir + "/cmodule.c",
+ DistDir + "/setup.py"]:
+ assert not os.system("cp %s %s" % (filename, tardir)), filename
+
+ os.mkdir(tardir+"/rdiff_backup")
+ for filename in ["connection.py", "destructive_stepping.py",
+ "FilenameMapping.py", "Globals.py", "Hardlink.py",
+ "highlevel.py", "increment.py", "__init__.py",
+ "iterfile.py", "lazy.py", "log.py", "Main.py",
+ "manage.py", "MiscStats.py", "Rdiff.py", "restore.py",
+ "rlist.py", "robust.py", "rorpiter.py", "rpath.py",
+ "selection.py", "SetConnections.py", "static.py",
+ "statistics.py", "Time.py"]:
+ assert not os.system("cp %s/%s %s/rdiff_backup" %
+ (SourceDir, filename, tardir)), filename
+ os.chmod(os.path.join(tardir, "setup.py"), 0755)
os.chmod(os.path.join(tardir, "rdiff-backup"), 0755)
CopyMan(os.path.join(tardir, "rdiff-backup.1"), version)
os.system("tar -cvzf %s %s" % (tarfile, tardir))
diff --git a/rdiff-backup/dist/makerpm b/rdiff-backup/dist/makerpm
index 70c5edc..a5e87e3 100755
--- a/rdiff-backup/dist/makerpm
+++ b/rdiff-backup/dist/makerpm
@@ -6,7 +6,7 @@ SourceDir = "src"
def GetVersion():
"""Return version string by reading in ./rdiff-backup"""
- fp = open(SourceDir + "/rdiff-backup", "r")
+ fp = open("rdiff-backup", "r")
match = re.search("Version (.*?) ", fp.read())
fp.close()
return match.group(1)
@@ -26,21 +26,14 @@ else:
base = ".".join(specfile.split(".")[:-1])
srcrpm = base+".src.rpm"
-noarchrpm = base+".noarch.rpm"
+i386rpm = base+".i386.rpm"
+source_rpm = base+".src.rpm"
tarfile = "-".join(base.split("-")[:-1]) + ".tar.gz"
-redhat_srcrpm = base+"rh7x.src.rpm"
-redhat_noarchrpm = base+"rh7x.noarch.rpm"
-redhat_patch = "rdiff-backup-rh7x.patch"
-redhat_specfile = "rdiff-backup-%s-1.rh7x.spec" % version
-
-#os.system("install -o root -g root -m 644 %s %s /usr/src/redhat/SOURCES" %
-# (tarfile, redhat_patch))
-os.system("install -o root -g root -m 644 %s /usr/src/redhat/SOURCES" %
- (tarfile,))
-os.system("rpm -ba --sign -vv --target noarch " + specfile)
-#os.system("rpm -ba --sign -vv --target noarch.rh7x " + redhat
-
-#os.system("install -o ben -g ben -m 644 /usr/src/redhat/SRPMS/%s ." % srcrpm)
-os.system("install -o ben -g ben -m 644 /usr/src/redhat/RPMS/noarch/%s ." %
- noarchrpm)
+assert not os.system("install -o root -g root -m 644 %s "
+ "/usr/src/redhat/SOURCES" % (tarfile,))
+assert not os.system("rpm -ba --sign -vv --target i386 " + specfile)
+assert not os.system("install -o ben -g ben -m 644 "
+ "/usr/src/redhat/RPMS/i386/%s ." % i386rpm)
+assert not os.system("install -o ben -g ben -m 644 "
+ "/usr/src/redhat/SRPMS/%s ." % source_rpm)
diff --git a/rdiff-backup/dist/rdiff-backup.spec b/rdiff-backup/dist/rdiff-backup.spec
index b77e64b..b587ea9 100644
--- a/rdiff-backup/dist/rdiff-backup.spec
+++ b/rdiff-backup/dist/rdiff-backup.spec
@@ -6,7 +6,8 @@ Source: %{name}-%{version}.tar.gz
Copyright: GPL
Group: Applications/Archiving
BuildRoot: %{_tmppath}/%{name}-root
-requires: librsync, python >= 2.2
+requires: librsync, python2 >= 2.2
+BuildPrereq: python2-devel >= 2.2
%description
rdiff-backup is a script, written in Python, that backs up one
@@ -24,22 +25,20 @@ differences from the previous backup will be transmitted.
%setup
%build
+./setup.py build
%install
-rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT/usr/bin
-mkdir -p $RPM_BUILD_ROOT/usr/share/man/man1
-
-install -m 755 rdiff-backup $RPM_BUILD_ROOT/usr/bin/rdiff-backup
-install -m 644 rdiff-backup.1 $RPM_BUILD_ROOT/usr/share/man/man1/rdiff-backup.1
+./setup.py install --prefix=$RPM_BUILD_ROOT/usr
%clean
%files
%defattr(-,root,root)
+%doc CHANGELOG COPYING README FAQ.html
+/usr/lib/python2.2/site-packages/rdiff_backup
/usr/bin/rdiff-backup
/usr/share/man/man1/rdiff-backup.1.gz
-%doc CHANGELOG COPYING README FAQ.html
+
%changelog
* Sun Nov 4 2001 Ben Escoto <bescoto@stanford.edu>
diff --git a/rdiff-backup/dist/setup.py b/rdiff-backup/dist/setup.py
index 72f63c6..49829bd 100755
--- a/rdiff-backup/dist/setup.py
+++ b/rdiff-backup/dist/setup.py
@@ -1,14 +1,17 @@
#!/usr/bin/env python
-import sys
+import sys, os, getopt
from distutils.core import setup, Extension
+version_string = "0.9.0"
+
if sys.version_info[:2] < (2,2):
print "Sorry, rdiff-backup requires version 2.2 or later of python"
sys.exit(1)
+
setup(name="rdiff-backup",
- version="0.9.0",
+ version=version_string,
description="Local/remote mirroring+incremental backup",
author="Ben Escoto",
author_email="bescoto@stanford.edu",
@@ -16,3 +19,24 @@ setup(name="rdiff-backup",
packages = ['rdiff_backup'],
ext_modules=[Extension("rdiff_backup.C", ["cmodule.c"])])
+install = 0
+prefix = "/usr"
+for arg in sys.argv[1:]: # check for "install" and --prefix arg
+ if arg == "install": install = 1
+ elif arg.startswith("--prefix="):
+ prefix = arg[len("--prefix="):]
+
+if install:
+ print "Copying rdiff-backup to %s/bin" % prefix
+ assert not os.system("install -D -m0755 rdiff-backup "
+ "%s/bin/rdiff-backup" % prefix)
+ print "Copying rdiff-backup.1 to %s/share/man/man1" % prefix
+ assert not os.system("install -D -m0644 rdiff-backup.1 "
+ "%s/share/man/man1/rdiff-backup" % prefix)
+ print ("Copying CHANGELOG, COPYING, README, and FAQ.html to "
+ "%s/share/doc/rdiff-backup-%s" % (prefix, version_string))
+ assert not os.system("install -d %s/share/doc/rdiff-backup-%s" %
+ (prefix, version_string))
+ assert not os.system("install -m0644 CHANGELOG COPYING README FAQ.html "
+ "%s/share/doc/rdiff-backup-%s" %
+ (prefix, version_string))