summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorben <ben@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2002-06-19 09:54:46 +0000
committerben <ben@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2002-06-19 09:54:46 +0000
commitb108debb74980f900c61fec1370b6aae9db5f8aa (patch)
treefccff8e06819dbe6d4ef09ebe4f119928fc9437d
parent9e4b8b40f80eef0a785ed73d95c99cfd54478fd8 (diff)
downloadrdiff-backup-b108debb74980f900c61fec1370b6aae9db5f8aa.tar.gz
Final changes for 0.9.1
git-svn-id: http://svn.savannah.nongnu.org/svn/rdiff-backup/trunk@139 2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109
-rw-r--r--rdiff-backup/CHANGELOG11
-rw-r--r--rdiff-backup/README18
-rw-r--r--rdiff-backup/TODO2
-rwxr-xr-xrdiff-backup/rdiff-backup16
4 files changed, 37 insertions, 10 deletions
diff --git a/rdiff-backup/CHANGELOG b/rdiff-backup/CHANGELOG
index 7a514d5..d22dbe2 100644
--- a/rdiff-backup/CHANGELOG
+++ b/rdiff-backup/CHANGELOG
@@ -1,3 +1,14 @@
+New in v0.9.1 (2002/06/19)
+--------------------------
+
+Fixed some bad C. Besides being unportable and leaking memory, it may
+have lead to someone's backup directory getting deleted (?).
+
+Tweaked some error recovery code to make it more like 0.8.0.
+
+Improved the installation a bit.
+
+
New in v0.9.0 (2002/06/17)
--------------------------
diff --git a/rdiff-backup/README b/rdiff-backup/README
index b149fbf..f70059c 100644
--- a/rdiff-backup/README
+++ b/rdiff-backup/README
@@ -1,7 +1,18 @@
+INSTALLATION:
+
Thank you for trying rdiff-backup. To install, run:
./setup.py install
+The default prefix is /usr, so files are put in /usr/bin,
+/usr/share/man/, etc. An alternate prefix can be specified using the
+--prefix=<prefix> option. For example:
+
+ ./setup.py install --prefix=/usr/local
+
+
+REQUIREMENTS:
+
Remember that you must have Python 2.2 or later and librsync installed
(this means that "python" and "rdiff" should be in your path). To
download, see http://www.python.org and
@@ -11,8 +22,9 @@ For remote operation, rdiff-backup should be in installed and in the
PATH on remote system(s) (see man page for more information).
-If you have the above installed, and it still doesn't work, see the
-web page at http://rdiff-backup.stanford.edu for more
-information.
+TROUBLESHOOTING:
+If you have everything installed properly, and it still doesn't work,
+see the enclosed FAQ.html, the web page at
+http://rdiff-backup.stanford.edu, and/or the mailing list.
diff --git a/rdiff-backup/TODO b/rdiff-backup/TODO
index 4a8aaee..a494525 100644
--- a/rdiff-backup/TODO
+++ b/rdiff-backup/TODO
@@ -4,7 +4,7 @@ Write some better selection test cases to test new Iterate_fast func.
Considering rewriting Selection Iterate(_fast) code again.
-Fix up headers on source code files, update README.
+Fix remaining memory leaks in cmodule.c
---------[ Long term ]---------------------------------------
diff --git a/rdiff-backup/rdiff-backup b/rdiff-backup/rdiff-backup
index dfe18fa..10981f2 100755
--- a/rdiff-backup/rdiff-backup
+++ b/rdiff-backup/rdiff-backup
@@ -1,17 +1,21 @@
#!/usr/bin/env python
#
# rdiff-backup -- Mirror files while keeping incremental changes
-# Version 0.9.0 released June 17, 2002
+# Version 0.9.1 released June 20, 2002
# Copyright (C) 2001, 2002 Ben Escoto <bescoto@stanford.edu>
#
# This program is licensed under the GNU General Public License (GPL).
-# Distributions of rdiff-backup usually include a copy of the GPL in a
-# file called COPYING. The GPL is also available online at
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License as published by the Free Software Foundation,
+# Inc., 675 Mass Ave, Cambridge MA 02139, USA; either version 2 of the
+# License, or (at your option) any later version. Distributions of
+# rdiff-backup should include a copy of the GPL in a file called
+# COPYING. The GPL is also available online at
# http://www.gnu.org/copyleft/gpl.html.
#
-# See http://www.stanford.edu/~bescoto/rdiff-backup for more
-# information. Please send mail to me or the mailing list if you find
-# bugs or have any suggestions.
+# See http://rdiff-backup.stanford.edu/ for more information. Please
+# send mail to me or the mailing list if you find bugs or have any
+# suggestions.
import sys
import rdiff_backup.Main