summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorowsla <owsla@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2008-07-14 15:27:46 +0000
committerowsla <owsla@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2008-07-14 15:27:46 +0000
commit703994f05a17f46e54edc8cb23f7d6a3bf4620ca (patch)
tree680d0072cccc5d18060216a0d8c665a34cbdcca7
parentc39337dbf6c9f188e2895981a95e647637c8054b (diff)
downloadrdiff-backup-703994f05a17f46e54edc8cb23f7d6a3bf4620ca.tar.gz
Put Windows-specific code at the outer level, not incorrectly inside the
argument loop. (Bug fix from Josh Nisly) git-svn-id: http://svn.savannah.nongnu.org/svn/rdiff-backup/trunk@913 2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109
-rwxr-xr-xrdiff-backup/dist/setup.py31
1 files changed, 16 insertions, 15 deletions
diff --git a/rdiff-backup/dist/setup.py b/rdiff-backup/dist/setup.py
index 3a011ee..964e122 100755
--- a/rdiff-backup/dist/setup.py
+++ b/rdiff-backup/dist/setup.py
@@ -41,21 +41,22 @@ if os.name == 'posix' or os.name == 'nt':
libdir_list = [os.path.join(LIBRSYNC_DIR, 'lib')]
if '-lrsync' in LIBS:
libname = []
- if os.name == 'nt':
- try:
- import py2exe
- except ImportError:
- pass
- else:
- extra_options = {
- 'console': ['rdiff-backup'],
- }
- if '--single-file' in sys.argv[1:]:
- sys.argv.remove('--single-file')
- extra_options.update({
- 'options': {'py2exe': {'bundle_files': 1}},
- 'zipfile': None
- })
+
+if os.name == 'nt':
+ try:
+ import py2exe
+ except ImportError:
+ pass
+ else:
+ extra_options = {
+ 'console': ['rdiff-backup'],
+ }
+ if '--single-file' in sys.argv[1:]:
+ sys.argv.remove('--single-file')
+ extra_options.update({
+ 'options': {'py2exe': {'bundle_files': 1}},
+ 'zipfile': None
+ })
setup(name="rdiff-backup",
version=version_string,