summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorowsla <owsla@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2008-07-13 19:58:55 +0000
committerowsla <owsla@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2008-07-13 19:58:55 +0000
commita75f11bc2539ce5f56bf96822ab76888492d0a8e (patch)
tree92dde5e98f38f908acd5176632a7a579e73b6687
parenteeee83920af9ad5b423bd8f6cb6731394bbb28f2 (diff)
downloadrdiff-backup-a75f11bc2539ce5f56bf96822ab76888492d0a8e.tar.gz
Catch EPERM error when trying to write extended attributes.
git-svn-id: http://svn.savannah.nongnu.org/svn/rdiff-backup/trunk@911 2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109
-rw-r--r--rdiff-backup/CHANGELOG2
-rw-r--r--rdiff-backup/rdiff_backup/eas_acls.py4
2 files changed, 4 insertions, 2 deletions
diff --git a/rdiff-backup/CHANGELOG b/rdiff-backup/CHANGELOG
index da71319..01a2626 100644
--- a/rdiff-backup/CHANGELOG
+++ b/rdiff-backup/CHANGELOG
@@ -1,6 +1,8 @@
New in v1.1.17 (????/??/??)
---------------------------
+Catch EPERM error when trying to write extended attributes. (Andrew Ferguson)
+
Allow rdiff-backup to be built into a single executable on Windows using
py2exe ("setup.py py2exe --single-file"). (Patch from Josh Nisly)
diff --git a/rdiff-backup/rdiff_backup/eas_acls.py b/rdiff-backup/rdiff_backup/eas_acls.py
index 5077b6a..6b1e128 100644
--- a/rdiff-backup/rdiff_backup/eas_acls.py
+++ b/rdiff-backup/rdiff_backup/eas_acls.py
@@ -111,8 +111,8 @@ class ExtendedAttributes:
except IOError, exc:
# Mac and Linux attributes have different namespaces, so
# fail gracefully if can't call setxattr
- if exc[0] == errno.EOPNOTSUPP or exc[0] == errno.EACCES \
- or exc[0] == errno.ENOENT:
+ if exc[0] in (errno.EOPNOTSUPP, errno.EPERM, errno.EACCES,
+ errno.ENOENT):
log.Log("Warning: unable to write xattr %s to %s"
% (name, repr(rp.path)), 6)
continue