summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordgaudet <dgaudet@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2006-11-12 07:24:36 +0000
committerdgaudet <dgaudet@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2006-11-12 07:24:36 +0000
commit42ef6287960db20160352a6641ba7c91dad503d7 (patch)
tree42187ff40d7aec9ec6609fd89df1e88cf8587405
parent55fb0bb52952519dd33bea87ed013bc8a8f85f14 (diff)
downloadrdiff-backup-42ef6287960db20160352a6641ba7c91dad503d7.tar.gz
i don't run redhat/fedora, so i can't build the srpm/rpm... so instead i'm
including the specfiles in the tarball for others to use. git-svn-id: http://svn.savannah.nongnu.org/svn/rdiff-backup/trunk@767 2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109
-rwxr-xr-xrdiff-backup/dist/makedist10
1 files changed, 5 insertions, 5 deletions
diff --git a/rdiff-backup/dist/makedist b/rdiff-backup/dist/makedist
index a67cc7f..defb6f6 100755
--- a/rdiff-backup/dist/makedist
+++ b/rdiff-backup/dist/makedist
@@ -90,7 +90,7 @@ def VersionedCopy(source, dest, munge_date = 0):
fout.write(outbuf)
assert not fout.close()
-def MakeTar():
+def MakeTar(specfiles):
"""Create rdiff-backup tar file"""
tardir = "rdiff-backup-%s" % Version
tarfile = "rdiff-backup-%s.tar.gz" % Version
@@ -103,7 +103,7 @@ def MakeTar():
"FAQ.html", "examples.html",
SourceDir + "/cmodule.c",
SourceDir + "/_librsyncmodule.c",
- DistDir + "/setup.py"]:
+ DistDir + "/setup.py"] + specfiles:
assert not os.system("cp %s %s" % (filename, tardir)), filename
os.mkdir(tardir+"/rdiff_backup")
@@ -141,7 +141,7 @@ def MakeSpecFile():
specfile, fedora_specfile= "rdiff-backup.spec", "rdiff-backup.spec-fedora"
VersionedCopy(spec_template, specfile)
VersionedCopy(fedora_spec_template, fedora_specfile)
- return specfile, fedora_specfile
+ return [specfile, fedora_specfile]
def parse_cmdline(arglist):
"""Returns action"""
@@ -168,10 +168,10 @@ def Main():
if action != "HTML":
assert action == "All"
print "Processing version " + Version
- tarfile = MakeTar()
- print "Made tar file " + tarfile
specfiles = MakeSpecFile()
print "Made specfiles ", specfiles
+ tarfile = MakeTar(specfiles)
+ print "Made tar file " + tarfile
if __name__ == "__main__" and not globals().has_key('__no_execute__'):