summaryrefslogtreecommitdiff
path: root/rdiff-backup/dist/makerpm
diff options
context:
space:
mode:
authorben <ben@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2002-04-08 09:13:48 +0000
committerben <ben@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2002-04-08 09:13:48 +0000
commit6fe0035bb3eaf59d8a7fe13c230c534619dba04b (patch)
tree475c7a641fc84bf3a960ec615fb330c6aec8e4f5 /rdiff-backup/dist/makerpm
parent34d29a9d9961f4ba481828385364fa7c9a6fb2dc (diff)
downloadrdiff-backup-6fe0035bb3eaf59d8a7fe13c230c534619dba04b.tar.gz
Thought about making separate redhat 7.x RPMs, now I don't think I'll bother
git-svn-id: http://svn.savannah.nongnu.org/svn/rdiff-backup/trunk@38 2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109
Diffstat (limited to 'rdiff-backup/dist/makerpm')
-rwxr-xr-xrdiff-backup/dist/makerpm14
1 files changed, 11 insertions, 3 deletions
diff --git a/rdiff-backup/dist/makerpm b/rdiff-backup/dist/makerpm
index 5f3a488..8fc3027 100755
--- a/rdiff-backup/dist/makerpm
+++ b/rdiff-backup/dist/makerpm
@@ -13,7 +13,8 @@ def GetVersion():
if len(sys.argv) == 1:
- specfile = "rdiff-backup-%s-1.spec" % GetVersion()
+ version = GetVersion()
+ specfile = "rdiff-backup-%s-1.spec" % version
print "Using specfile %s" % specfile
elif len(sys.argv) == 2:
specfile = sys.argv[1]
@@ -28,9 +29,16 @@ srcrpm = base+".src.rpm"
noarchrpm = base+".noarch.rpm"
tarfile = "-".join(base.split("-")[:-1]) + ".tar.gz"
-os.system("install -o root -g root -m 644 %s /usr/src/redhat/SOURCES" %
- tarfile)
+redhat_srcrpm = base+"rh7x.src.rpm"
+redhat_noarchrpm = base+"rh7x.noarch.rpm"
+redhat_patch = "rdiff-backup-rh7x.patch"
+redhat_specfile = "rdiff-backup-%s-1.rh7x.spec" % version
+
+os.system("install -o root -g root -m 644 %s %s /usr/src/redhat/SOURCES" %
+ tarfile, redhat_patch)
os.system("rpm -ba --sign -vv --target noarch " + specfile)
+os.system("rpm -ba --sign -vv --target noarch.rh7x " + redhat
+
#os.system("install -o ben -g ben -m 644 /usr/src/redhat/SRPMS/%s ." % srcrpm)
os.system("install -o ben -g ben -m 644 /usr/src/redhat/RPMS/noarch/%s ." %
noarchrpm)