summaryrefslogtreecommitdiff
path: root/rdiff-backup/dist
diff options
context:
space:
mode:
authorbescoto <bescoto@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2003-07-22 10:44:50 +0000
committerbescoto <bescoto@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2003-07-22 10:44:50 +0000
commitb2b876fdc2544ffa01bb41228f50ede90298f638 (patch)
tree337b96250afd4465a75daf8a1783c5de4c590733 /rdiff-backup/dist
parent3617a1f5be2c8c90d2e3c98a642279c58981c3d7 (diff)
downloadrdiff-backup-b2b876fdc2544ffa01bb41228f50ede90298f638.tar.gz
Final changes for 0.13.0 (small test changes, Fedora spec packaging)
git-svn-id: http://svn.savannah.nongnu.org/svn/rdiff-backup/trunk@356 2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109
Diffstat (limited to 'rdiff-backup/dist')
-rwxr-xr-xrdiff-backup/dist/makedist5
-rwxr-xr-xrdiff-backup/dist/makerpm14
-rw-r--r--rdiff-backup/dist/rdiff-backup.spec.template (renamed from rdiff-backup/dist/rdiff-backup.spec)22
3 files changed, 22 insertions, 19 deletions
diff --git a/rdiff-backup/dist/makedist b/rdiff-backup/dist/makedist
index 511afc6..cc337ff 100755
--- a/rdiff-backup/dist/makedist
+++ b/rdiff-backup/dist/makedist
@@ -7,8 +7,7 @@ DistDir = "dist"
# Various details about the files must also be specified by the rpm
# spec template.
-spec_template = "dist/rdiff-backup.spec"
-#redhat_spec_template = "dist/rdiff-backup.rh7x.spec"
+spec_template = "dist/rdiff-backup.spec.template"
def CopyMan(destination, version):
"""Create updated man page at the specified location"""
@@ -115,7 +114,7 @@ def MakeTar():
def MakeSpecFile():
"""Create spec file using spec template"""
- specfile = "rdiff-backup-%s-2.spec" % Version
+ specfile = "rdiff-backup.spec"
VersionedCopy(spec_template, specfile)
return specfile
diff --git a/rdiff-backup/dist/makerpm b/rdiff-backup/dist/makerpm
index cddfdb2..129cbed 100755
--- a/rdiff-backup/dist/makerpm
+++ b/rdiff-backup/dist/makerpm
@@ -6,23 +6,23 @@ rpmroot = "/home/ben/rpm"
if len(sys.argv) == 2:
version = sys.argv[1]
- specfile = "rdiff-backup-%s-2.spec" % version
+ specfile = "rdiff-backup.spec"
print "Using specfile %s" % specfile
else:
print "Syntax: %s version_number" % sys.argv[0]
sys.exit(1)
-base = ".".join(specfile.split(".")[:-1])
-srcrpm = base+".src.rpm"
-i386rpm = base+".i386.rpm"
-source_rpm = base+".src.rpm"
-tarfile = "-".join(base.split("-")[:-1]) + ".tar.gz"
+base = "rdiff-backup-%s" % (version,)
+tarfile = base + ".tar.gz"
+rpmbase = base + "-0.fdr.1" # Fedora suffix, with release number 1
+i386_rpm = rpmbase + ".i386.rpm"
+source_rpm = rpmbase + ".src.rpm"
# These assume the rpm root directory $HOME/rpm. The
# nonstandard location allows for building by non-root user.
assert not os.system("cp %s %s/SOURCES" % (tarfile, rpmroot))
#assert not os.system("rpm -ba --sign -vv --target i386 " + specfile)
assert not os.system("rpmbuild -ba -v --sign " + specfile)
-assert not os.system("mv %s/RPMS/i386/%s ." % (rpmroot, i386rpm))
+assert not os.system("mv %s/RPMS/i386/%s ." % (rpmroot, i386_rpm))
assert not os.system("mv %s/SRPMS/%s ." % (rpmroot, source_rpm))
diff --git a/rdiff-backup/dist/rdiff-backup.spec b/rdiff-backup/dist/rdiff-backup.spec.template
index 2073b51..0249336 100644
--- a/rdiff-backup/dist/rdiff-backup.spec
+++ b/rdiff-backup/dist/rdiff-backup.spec.template
@@ -3,13 +3,14 @@
Version: $version
Summary: Convenient and transparent local/remote incremental mirror/backup
Name: rdiff-backup
-Release: 2
-URL: http://www.stanford.edu/~bescoto/rdiff-backup/
-Source: %{name}-%{version}.tar.gz
-Copyright: GPL
+Release: 0.fdr.1
+Epoch: 0
+URL: http://rdiff-backup.stanford.edu/
+Source: http://rdiff-backup.stanford.edu/%{name}-%{version}.tar.gz
+License: GPL
Group: Applications/Archiving
-BuildRoot: %{_tmppath}/%{name}-root
-requires: librsync >= 0.9.5.1, %{PYTHON_NAME} >= 2.2
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Requires: librsync >= 0.9.5.1, %{PYTHON_NAME} >= 2.2
BuildPrereq: %{PYTHON_NAME}-devel >= 2.2, librsync-devel >= 0.9.5.1
%description
@@ -38,12 +39,15 @@ differences from the previous backup will be transmitted.
%files
%defattr(-,root,root)
-/usr/bin/rdiff-backup
-/usr/share/man/man1
-/usr/lib
+%{_bindir}/rdiff-backup
+%{_mandir}/man1/rdiff-backup*
+%{_libdir}/
%doc CHANGELOG COPYING FAQ.html README
%changelog
+* Sun Jul 20 2003 Ben Escoto <bescoto@stanford.edu>
+- Minor changes to comply with Fedora standards.
+
* Sun Jan 19 2002 Troels Arvin <troels@arvin.dk>
- Builds, no matter if Python 2.2 is called python2-2.2 or python-2.2.