summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@whiskeymedia.com>2013-04-27 13:23:17 -0700
committerandy <andy@whiskeymedia.com>2013-04-27 13:23:17 -0700
commit12bc5ae983d4d5229ef24978c72817fbd409b540 (patch)
tree563303e9b6fa9daa88a5669af8c650ad62b37ad7
parenta789debc90a14a4cc4979a2105601ba6a8150d12 (diff)
downloadredis-py-12bc5ae983d4d5229ef24978c72817fbd409b540.tar.gz
run fewer pep8 builds
-rw-r--r--.travis.yml9
1 files changed, 6 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index ec1d10a..2ff5dca 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,10 +5,13 @@ python:
- "2.7"
- "2.6"
- "2.5"
-env:
- - TEST_PEP8=0
- - TEST_PEP8=1
install:
- pip install -e . --use-mirrors
- "if [[ $TEST_PEP8 == '1' ]]; then pip install pep8 --use-mirrors; fi"
script: "if [[ $TEST_PEP8 == '1' ]]; then pep8 --repeat --show-source --exclude=.venv,.tox,dist,doc,build,*.egg .; else python setup.py test; fi"
+matrix:
+ include:
+ - python: 2.7
+ env: TEST_PEP8=1
+ - python: 3.3
+ env: TEST_PEP8=1