summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@whiskeymedia.com>2013-05-01 16:02:28 -0700
committerandy <andy@whiskeymedia.com>2013-05-01 16:02:28 -0700
commit7c5027e475fe53e0d7e718855ebdd9e294fdafb3 (patch)
tree88f6eb860c1ccd79d13be177b0b070ed3955f3af
parent8062897a973525a352594a7ebe6854918e75b944 (diff)
downloadredis-py-7c5027e475fe53e0d7e718855ebdd9e294fdafb3.tar.gz
separate travis builds for hiredis
-rw-r--r--.travis.yml4
1 files changed, 4 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
index 2ff5dca..8bcd92c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,9 +5,13 @@ python:
- "2.7"
- "2.6"
- "2.5"
+env:
+ - TEST_HIREDIS=0
+ - TEST_HIREDIS=1
install:
- pip install -e . --use-mirrors
- "if [[ $TEST_PEP8 == '1' ]]; then pip install pep8 --use-mirrors; fi"
+ - "if [[ $TEST_HIREDIS == '1' ]]; then pip install hiredis --use-mirrors; fi"
script: "if [[ $TEST_PEP8 == '1' ]]; then pep8 --repeat --show-source --exclude=.venv,.tox,dist,doc,build,*.egg .; else python setup.py test; fi"
matrix:
include: