summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2021-12-09 08:45:14 +0100
committerGitHub <noreply@github.com>2021-12-09 09:45:14 +0200
commita58f4235e554cb50b312caf1a9076114c77d0529 (patch)
tree4ad2bcd9739f1f4f65f310ff6ca714dca0e30bbf
parent291baa93b8712d104ce50a61f52e23b68e2b7a99 (diff)
downloadredis-py-a58f4235e554cb50b312caf1a9076114c77d0529.tar.gz
Add packaging to setup_requires, and use >= to play nice to setup.py (fixes #1625) (#1780)
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 58d753f..b9c2e3e 100644
--- a/setup.py
+++ b/setup.py
@@ -26,9 +26,12 @@ setup(
author="Redis Inc.",
author_email="oss@redis.com",
python_requires=">=3.6",
+ setup_requires=[
+ "packaging>=21.3",
+ ],
install_requires=[
- "deprecated==1.2.3",
- "packaging==21.3",
+ "deprecated>=1.2.3",
+ "packaging>=21.3",
],
classifiers=[
"Development Status :: 5 - Production/Stable",